0

I just turned one of my old laptops into some of a VPS with Ubuntu Server; just to mess around on. But im having an issue...

I'd like to trasnfer some files over using FileZilla (SFTP), but using my normal login with wont work as it wont let me upload files without root access.

I've tried using passwd -u root, and it comes back with it has been successfuly unlocked and i changed the password to just "test" for now. But its still not working...

I can login with root on the laptop itself, but using SSH or SFTP it still says "access denied" or "Authentication failed.".

Any help?

0

You didn't say which version of Ubuntu Server that you're running, or what FTP server software you're using, but answers to this question, which I discovered with a web search for "Ubuntu ssh root", say that root access via ssh is disabled by default in Ubuntu Server 14.04. It's probably also disabled in your version. You can enable it by editing /etc/ssh/sshd_config.

However, it should be mentioned that there are excellent security reasons to not allow logging in remotely as root. You're probably better off logging in with your usual user name, and using su to do things that require root privileges.

I imagine that you tried FTPing files out of desperation, but if you can get in via ssh then scp is generally a more flexible way to copy files over.

  • If you found my answer helpful, please consider upvoting and accepting it. – rclocher3 Nov 24 '16 at 17:10
0

You need to enable ssh to log in as root. To do so edit:

/etc/ssh/sshd_config

Find

PermitRootLogin without-password 

to

PermitRootLogin yes

and them restart ssh with

service ssh restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.