0

I finished installing Ubuntu

My system runs on a low res (1024x768)

Trying to install proprietary amd drivers instead of Xorg crashes the program

Trying to install drivers from amd site fails and gets me into low res mode(640x480)

and then system wont boot in graphics mode

Also it R7 265 is recognised as HD 7850

2
  • Same graphics card here, installed incompatible stuck in login loop. Removing driver solved my problem.
    – Rahul
    Nov 23, 2016 at 19:25
  • I have reinstalled Ubuntu now but I still have this odd resolution (1024x768) and I cant change it in settings
    – Zac G
    Nov 23, 2016 at 19:27

2 Answers 2

0

I ran into similar problems. LinuxMint 17.3 (Ubuntu 14.04) does well on my dual monitor configuration. That is, using the proprietary fglrx driver. I can get 1440x900 on both displays, even though one connection is VGA straight and the other VGA through a HDMI-to-VGA converter.

Using an AMD Radeon HD 6450 PCI_e graphics card and 2 Asus VE198S LED monitors, with 1440x900 as max resolution and VGA/DVI-D/HDMI ports.

Whatever I tried - running LinuxMint 18 with either KDE or Cinnamon as live distro from a USB stick - I could not get anything better than a disappointing 1024x768 resolution on both screens. So, I'll stick to Ubuntu 14.04 and fglrx as long as necessary (and possible).

[EDIT:] Maybe this information is helpful? > Ubuntu 16.04 and amdgpu issues

0

I know it's too late, but I'm gonna answer for the sake of community.

First of all, it's normal that your graphics card is detected as HD 7850. Here's a snippet of lspci command: VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP]

I found a workaround to solve your issue, but first you need to uninstall the AMD drivers you installed. The solution is simply to add a custom resolution. I quoted the answer form another thread with some minor edits How to set a custom resolution?

Use cvt
Syntax is: cvt width height refreshrate

ex. cvt 1680 1050 60

this gives you: # 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync

Now tell this to xrandr: xrandr --newmode "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync

Type xrandr This will show you some info. looks like this
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 16384 x 16384 DisplayPort-0 disconnected (normal left inverted right x axis y axis) HDMI-0 disconnected (normal left inverted right x axis y axis) DVI-0 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm 1024x768 60.00* 800x600 60.32 56.25
848x480 60.00
640x480 59.94
DVI-1 disconnected (normal left inverted right x axis y axis) 1680x1050_60.00 (0x5d1) 146.250MHz -HSync +VSync h: width 1680 start 1784 end 1960 total 2240 skew 0 clock 65.29KHz v: height 1050 start 1053 end 1059 total 1089 clock 59.95Hz

check the name of the connecting port in my case DVI-0

Then you can now add it to the table of possible resolutions of an output of your choice: xrandr --addmode DVI-0 1680x1050_60.00

Finally, Open Display settings and choose the new resolution you just add

Edit: you will notice that all of this disappear after restart
Type in Terminal your last 2 commands at this form in this case: echo "xrandr --newmode "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync; xrandr --addmode DVI-0 1680x1050_60.00" >> fix.sh
Search for "Startup Application" and browse the file you just created in command field, then hit OK.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.