5

This question already has an answer here:

I followed this guide to install Virtualbox, but it failed eventually and I get this error message

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/sbin/vboxconfig'

as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

When I ran this command # sudo /sbin/vboxconfig I get this

vboxdrv.sh: Building VirtualBox kernel modules. vboxdrv.sh: Starting VirtualBox services. vboxdrv.sh: Building VirtualBox kernel modules. vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.

There were problems setting up VirtualBox. To re-start the set-up process, run /sbin/vboxconfig as root.

and here's the last three lines of dmesg output:

[   44.698246] wlo1: Limiting TX power to 20 (20 - 0) dBm as advertised by 00:18:0a:79:2c:79
[  163.080255] capability: warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)
[ 2349.627558] [drm:intel_pipe_update_end [i915_bpo]] *ERROR* Atomic update failure on pipe A (start=142454 end=142455) time 484 us, min 1073, max 1079, scanline start 1061, end 1095

I tried to re-install dkms sudo apt-get install --reinstall virtualbox-dkms I get this error and nothing changes .

vboxpci.ko: Running module version sanity check. Error! Module version 5.0.24_Ubuntu for vboxpci.ko is not newer than what is already found in kernel 4.4.0-47-generic (5.1.10). You may override by specifying --force.

Any help will be appreciated. Thanks in advance.

marked as duplicate by George Udosen, Fabby, user68186, David Foerster, Eric Carvalho Apr 20 '18 at 19:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Do you really need 5.1? If you install it from Ubuntu software you will get 5.0.24 which works fine for me. – Katu Nov 23 '16 at 8:10
  • It gives me the same problem! – youta Nov 23 '16 at 8:47
2

GAD3R is very incorrect. Virtualbux did away with Virtualbox-dkms as of 5.1. They thought they had fixed this issue some other way. Here's an article with changelog attached: http://news.softpedia.com/news/virtualbox-5-1-will-no-longer-rely-on-dkms-for-module-rebuilding-on-linux-504858.shtml

With Ubuntu hosts the following is all you need to do. When you boot after kernel upgrade and you get the kernel module failed to load DBUS message issue the following from a terminal window of your choosing:

All you need to do is issue:

sudo dpkg-reconfigure virtualbox-5.1

Once you do you will get the setup message that it needs to create a system users group. Just hit enter and it will drop back to terminal and you will see a one liner stating the group already exists and a blank line below that. The module rebuild process is hidden behind this blank line. Wait until an interactive prompt returns (only takes a minute or 2). Then you will be good to go.

Also for other Host Linux OSes (or if you like to see more info on Ubuntu) the following command is all you need on any Linux host:

 /sbin/rcvboxdrv setup

This works the same as the older /etc/init.d/vboxdrv setup they have just changed the name.

  • I tried all of the above. With both vboxconfig and rcvboxdrv setup, the log file contained Makefile:187: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again. Stop. – Hedley Finger Sep 22 '17 at 6:09
0

Run the following command :

sudo add-apt-repository universe
sudo apt-get update 
sudo apt-get install linux-headers-$(uname -r)
sudo apt-get install build-essential 

Restart your system and use the newest kernel version

sudo apt-get install --reinstall virtualbox-5.1 dkms
  • 1
    I get this error addgroup: The group vboxusers' already exists as a system group. Exiting. vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why. There were problems setting up VirtualBox. To re-start the set-up process, run /sbin/vboxconfig as root.` – youta Nov 23 '16 at 11:28
  • Does the secure boot is enabled on your BIOS settings? – GAD3R Nov 23 '16 at 11:54
  • No. Do I have to enable it?.. If yes would it harm my PC ? currently I'm using two operating systems Windows 10 & Ubuntu 16 – youta Nov 23 '16 at 12:18
  • No do not enable it , it may cause a problem – GAD3R Nov 23 '16 at 12:24
0

In my case VirtualBox installation failed (virtualbox-dkms) because I used the latest (non-default) Ubuntu kernel and virtualbox-dkms has not been patched yet for that kernel:

$ sudo apt-get install virtualbox virtualbox-ext-pac virtualbox-guest-additions-iso virtualbox-dkms
...
ERROR (dkms apport): kernel package linux-headers-4.12.14-041214-generic is not supported
Error! Bad return status for module build on kernel: 4.12.14-041214-generic (x86_64)
Consult /var/lib/dkms/virtualbox/5.0.40/build/make.log for more information.
Job for virtualbox.service failed because the control process exited with error code. See "systemctl status virtualbox.service" and "journalctl -xe" for details.
invoke-rc.d: initscript virtualbox, action "restart" failed.
● virtualbox.service - LSB: VirtualBox Linux kernel module
   Loaded: loaded (/etc/init.d/virtualbox; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-10-23 02:31:15 CEST; 4ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 10851 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)
...

So, I ended up with installation of the latest VirtualBox from Oracle, which works fine:

  • Go to the Linux Downloads page
  • Download the latest .deb for your OS
  • Run sudo dpkg -i /path/to/debfile to install it

Not the answer you're looking for? Browse other questions tagged or ask your own question.