0

This question already has an answer here:

This seems to be similar to Ubuntu gets stuck in a Login Loop and Ubuntu Login Loop but nothing suggested at either of those two has worked.

I get the login screen. Whether I attempt to log in as myself, another user, or the Guest user, the screen goes black momentarily and returns to the login screen.

Here are the contents of my ~/.xsession-errors:

Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
init: gnome-session (Unity) main process (2548) terminated with status 1
init: unity-settings-daemon main process (2538) killed by TERM signal
init: Disconnected from notified D-Bus bus
init: logrotate main process (2446) killed by TERM signal
init: update-notifier-crash (/var/crash/_usr_lib_ibus_ibus-ui-gtk3.1001.crash) main process (2495) killed by TERM signal
init: xsession-init main process (2535) killed by TERM signal
init: hud main process (2542) killed by TERM signal
init: unity-panel-service main process (2553) killed by TERM signal
init: window-stack-bridge main process (2475) killed by KILL signal

As I noted, I tried pretty much everything I found at the referenced questions and nothing has worked - changing permissions and ownerships on .Xauthority and .ICEauthority, installing linux-headers-generic, reconfiguring/uninstalling/reinstalling lightdm, etc.

I'm kind of at a loss on how to proceed. Any ideas?

(Edit; the next day) One thing I hadn't tried was switching to gdm as described at Ubuntu gets stuck in a Login Loop. That was no help at all. After running dpkg-reconfigure gdm the login screen did not change at all, so I tried rebooting. After that, I got only a couple of seconds of display / active keyboard with each press of ctrl-alt-F2, and it took me about 10 minutes to successfully reconfigure for lightdm. I don't know if that's helpful to anyone reading this....

(Edit) Here is the output of sudo lshw -c video:

*-display
   description: 3D controller
   product: GM107GLM [Quadro M1000M]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a2
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:16 memory:dc000000-dcffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:e000(size=128) memory:dd000000-dd07ffff
*-display
   description: VGA compatible controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 06
   width: 64 bits
   clock: 33MHz
   capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915_bpo latency=0
   resources: irq:128 memory:db000000-dbffffff memory:70000000-7fffffff ioport:f000(size=64)

I can find some info on these drivers with lsmod:

$ lsmod | grep i915_bpo
i915_bpo             1306624  3 
intel_ips              20480  1 i915_bpo
i2c_algo_bit           16384  1 i915_bpo
drm_kms_helper        151552  2 i915_bpo,nvidia_drm
drm                   360448  5 i915_bpo,drm_kms_helper,nvidia_drm
video                  40960  3 i915_bpo,dell_wmi,dell_laptop

$ lsmod | grep nvidia
nvidia_drm             45056  0 
nvidia_modeset        765952  1 nvidia_drm
drm_kms_helper        151552  2 i915_bpo,nvidia_drm
drm                   360448  5 i915_bpo,drm_kms_helper,nvidia_drm
nvidia              11489280  1 nvidia_modeset

So I'm not sure the nvidia video driver belongs?

modinfo returns some info about i915_bpo:

modinfo i915_bpo
filename:       /lib/modules/4.4.0-47generic/kernel/ubuntu/i915/i915_bpo.ko
license:        GPL and additional rights
description:    Intel Graphics
author:         Intel Corporation
author:         Tungsten Graphics, Inc.
firmware:       i915/bxt_dmc_ver1.bin
firmware:       i915/skl_dmc_ver1.bin
firmware:       i915/kbl_dmc_ver1.bin
firmware:       i915/skl_guc_ver6.bin
srcversion:     A0AA67E6671AC7D4B380BAA
alias:          pci:v00008086d0000593Bsv*sd*bc03sc*i*
[etc.]

... but there is no info returned from modinfo for any of the nvidia.* drivers. I am thinking that the invidia drivers are either corrupted or do not belong, but I'm not sure what to try next. Thanks anyone for any help.

marked as duplicate by karel, Zanna, Eric Carvalho, Tom Brossman, dessert Oct 29 '18 at 22:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Those solution didn't in my case also but removing incompatible graphics driver worked just fine. Please check if you have installed any incompatible graphics driver recently. – Rahul Nov 23 '16 at 17:35
  • I haven't installed any graphics drivers, unless they came with an update pushed to me. Where can I look to make sure? – Mark Shaw Nov 23 '16 at 20:53
  • Added a couple of edits; see above. – Mark Shaw Nov 23 '16 at 22:34
  • remove nvidia driver if install any sudo nvidia-settings --uninstall and sudo apt-get remove --purge nvidia* – Rahul Nov 24 '16 at 4:01
  • There is no --uninstall option for nvidia-settings. However, I ran the apt-get remove command and that seems to have done the trick. Thank you so very much for your help! – Mark Shaw Nov 28 '16 at 2:26
0

Incompatible graphics driver causing this problem. Try to remove them using,

sudo nvidia-settings --uninstall

sudo apt-get remove --purge nvidia*

Not the answer you're looking for? Browse other questions tagged or ask your own question.