1

Whenever I add a repository using the add-apt-repository command, a Traceback is called regarding the files /usr/bin/lsb_release and /usr/lib/python3/dist-packages/lsb_release.py

(I'm using Ubuntu 16.04.1)

The output is the following when adding a repository:

Traceback (most recent call last):
  File "/usr/bin/lsb_release", line 98, in <module>
    main()
  File "/usr/bin/lsb_release", line 62, in main
    distinfo = lsb_release.get_distro_information(options.upstream)
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 344, in get_distro_information
    distinfo = guess_debian_release()
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 239, in guess_debian_release
    get_distro_info(distinfo['ID'])
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 41, in get_distro_info
    RELEASES_ORDER.sort(key=lambda n: float(n[0]))
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 41, in <lambda>
    RELEASES_ORDER.sort(key=lambda n: float(n[0]))
ValueError: could not convert string to float: '6.06 LTS'
Traceback (most recent call last):
  File "/usr/bin/lsb_release", line 98, in <module>
    main()
  File "/usr/bin/lsb_release", line 62, in main
    distinfo = lsb_release.get_distro_information(options.upstream)
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 344, in get_distro_information
    distinfo = guess_debian_release()
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 239, in guess_debian_release
    get_distro_info(distinfo['ID'])
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 41, in get_distro_info
    RELEASES_ORDER.sort(key=lambda n: float(n[0]))
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 41, in <lambda>
    RELEASES_ORDER.sort(key=lambda n: float(n[0]))
ValueError: could not convert string to float: '12.04 LTS'
Traceback (most recent call last):
  File "/usr/bin/lsb_release", line 98, in <module>
    main()
  File "/usr/bin/lsb_release", line 62, in main
    distinfo = lsb_release.get_distro_information(options.upstream)
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 344, in get_distro_information
    distinfo = guess_debian_release()
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 239, in guess_debian_release
    get_distro_info(distinfo['ID'])
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 41, in get_distro_info
    RELEASES_ORDER.sort(key=lambda n: float(n[0]))
  File "/usr/lib/python3/dist-packages/lsb_release.py", line 41, in <lambda>
    RELEASES_ORDER.sort(key=lambda n: float(n[0]))
ValueError: could not convert string to float: '12.04 LTS'

When I remove /usr/bin/lsb_release, I don't get that traceback, but in my system tray a red icon is shown to inform me that there's been an error getting the updates.

Thank you in advance.

2
  • Might be a bug, consider filing a bug report on Launchpad, please.
    – Byte Commander
    Nov 22 '16 at 21:14
  • I find this very odd: '6.06 LTS' And you have tagged it 16.04, but there's 12.04 is mentioned twice. Is this Ubuntu?
    – muru
    Nov 23 '16 at 1:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.