So, I'm not sure what caused this because I haven't messed with the sound system at all. But, for some reason the sound keeps breaking, that is, no sound is produced. Sometimes just a Dummy output exists and sometimes it detects everything and it can be seen in pulseaudio and the sound application, but still no sound is produced.

Now this appears to occur quite often, as there are many fixes on this internet. This command usually works for me:

sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop  linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop  linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

The problem is however, that this is very temporary usually after a reboot it's broken again.

Also, during the time that it is working the volume level doesn't change, it's either off or very loud. This appears to be because of PCM in alsamixer being set to 100%. So I turn that down, but if I change the volume it goes back up to 100%. I tried a solution which blocked it from going up to 100%, but the volume level stays fairly flat, it doesn't go from quiet to loud as it should.

Also my headphones are just not detected by my computer. They used to be until all this sound stuff started going wrong.

How can I just put everything back to normal?

I'm using a dell xps 13 with ubuntu 16.04. My soundcard is being detected by aplay -l.

  • Literally exactly the same problem as me - even on the same computer! (The Dell XPS13 really is very nice. Except for this.) I'm also having the same problem on my desktop, I was trying to fix it earlier today. Just now I turned on my laptop, checked that the sound was working, then installed updates (I haven't used the laptop for a few days) and now it doesn't work. Something in the most recent updates has broken the sound, on my laptop and desktop. I've tried booting an older kernel, didn't fix it. – seanlano Nov 22 '16 at 10:37
  • 1
    @seanlano It's unbelievably annoying isn't it? I think it happened when I did updates too. – Jamal Moir Nov 22 '16 at 10:40
  • Does this sound similar: askubuntu.com/questions/850228 – seanlano Nov 22 '16 at 10:41
  • OK so I looked at /var/log/apt/term.log, somewhere in this lot is the package that's ruined the sound: pastebin.com/KJXgsHmc. I can see libpulsedsp:amd64, pulseaudio-utils, pulseaudio-module-bluetooth, pulseaudio-module-x11, pulseaudio, libpulse-mainloop-glib0:amd64, libpulse0:amd64 that sound relevant. I'm going to try reverting these packages if I can, to see if that fixes it. Then I'll open a bug report. – seanlano Nov 22 '16 at 10:51
  • @seanlano Yeah that looks similar... Ah OK, hopefully that will fix it then. – Jamal Moir Nov 22 '16 at 10:56

Turns out that in my case, the squeezelite package was causing the issues.

I disabled it with:

sudo systemctl stop squeezelite.service
sudo systemctl disable squeezelite.service

Now I am not seeing the problem anymore. There is an existing bug report for this, here: https://bugs.launchpad.net/ubuntu/+source/squeezelite/+bug/1636253

This was my original answer, not really relevant anymore but I'll leave it here for context

I was also experiencing this problem, on the same Dell laptop model. For me, I was able to fix it by re-installing pulseaudio.

I note that your command above has some apt installs in it, but these packages aren't the same as in those in the command in the question.

sudo apt install --reinstall pulseaudio pulseaudio-utils pulseaudio-module-bluetooth pulseaudio-module-x11 libpulse-mainloop-glib0 libpulse0 libpulsedsp 

Then do a reboot.

UPDATE 1: Turns out that this only works for the first 30 seconds or so after the reboot. Then it crashes again, and I get no sound at all. :(

UPDATE 2: Actually, now it's been running for a while now and sound is still working. Over a few reboots. I've run the reinstall command several times now - I was hoping to reproduce this so I could file a bug, but now it won't break again.

UPDATE 3: OK it crashed again. I've filed a bug report. https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1643870

  • This didn't work for me the first time, so I tried it again, but instead of rebooting it did a cold reboot, which usually sorts the problem. Unfortunately the headphone jack isn't working and the volume is still not controllable. I do have sound though... For now. – Jamal Moir Nov 22 '16 at 12:24
  • I've added a bug report, could you go to it and mark it as affecting you too? Hopefully some Ubuntu devs can look at it. bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1643870 – seanlano Nov 22 '16 at 12:32
  • Again I've run the reinstall, works for me, for now. We'll see how long for though. – seanlano Nov 22 '16 at 12:35
  • 1
    I've marked it as affecting me because sometimes it does. However I think our problems are slightly different as sometimes I have outputs listed. Right not my speakers are listed and three HDMI outputs are listed but no sound is produced. – Jamal Moir Nov 22 '16 at 12:45
  • I don't suppose you happen to have the package squeezelite installed? It's a client for a Squeezebox audio distribution system. This is the only other thing I've changed recently that could possibly explain this. – seanlano Nov 22 '16 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.