1

I've looked across this forum, and on the internet and found many people asking what seems like similar questions to myself. However none of the solutions posed seem to solve my problem.

I haven't got a lot of experience with Ubuntu so please forgive any ignorance, but I've recently got a dedicated server and installed Ubuntu 14.04 on it. I'm using a Windows 10 machine and have access to the server via SSH.

I am attempting to install OpenVPN on the server and I'm following the instructions in this guide. However when I get to the point where it says:

Copy the following files to the client using a secure method:

/etc/openvpn/ca.crt
/etc/openvpn/easy-rsa/keys/client1.crt
/etc/openvpn/easy-rsa/keys/client1.key

As the client certificates and keys are only required on the client machine, you should remove them from the server.

I get stuck. How do I actually access this /etc folder? I normally access files using an FTP client, logging in as a user I created when I first setup the server, but this folder does not appear. Further the root login details I was emailed don't work when trying to login via FTP.

I would appreciate any help provided in as simple to understand terms as possible. Thanks in advance.

Chappas

  • On the Ubuntu computer, you should see etc in the root directory. What do you get when you enter ls / on the Ubuntu computer? – Service Manager Nov 21 '16 at 17:46
  • bin etc initrd.img.old lost+found opt run sys var boot home lib media proc sbin tmp vmlinuz dev initrd.img lib64 mnt root srv usr vmlinuz.old I get this. Also please note I don't have local access to the server. – Chappas Nov 21 '16 at 17:48
  • Ok, etc is the second folder you listed in your output. It doesn't matter that you don't have local access, but having sudo access is what will matter. Are you able to run commands with sudo, such as sudo apt-get install openvpn in the guide? – Service Manager Nov 21 '16 at 17:51
  • Yes I've created an account which lets me use Sudo called 'Chappas' however early in the openvpn guide it tells me to change my account to root, so I did this from the by typing 'sudo -i' – Chappas Nov 21 '16 at 17:54
  • 1
    You can use SFTP instead of FTP. Try "WinSCP" client with the SSH authentication properties. However, in my opinion you can put these files where you want (via FTP) and after that you can sudo cp them to the exact place (via SSH). It sounds like the ftp user doesn't have access permission to this folder and the ftp client just doesn't show it. – pa4080 Nov 21 '16 at 18:18
3

I would recommend that you upload the files in question via sftp or scp. This has the advantage of being able to use your existing SSH credentials. There's a great guide on how to do so at http://www.inmotionhosting.com/support/website/ftp/connecting-scp-sftp Once you have the files uploaded, I would sudo cp the files to their respective locations, and then adjust the ownership with chown, and the permissions with chmod to the necessary settings.

|improve this answer|||||
  • Perfect thank you, this has solved it. I followed the instructions in the link and was able to access the files via FTP with my SSH details. Thanks to all for their advice. – Chappas Nov 21 '16 at 19:21
  • @Chappas I'm glad to hear it! Would you be so kind as to accept the answer? – FCTW Nov 22 '16 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.