0

I want the OS to use English to display UI, but I need to read and write Japanese in applications and deal with files whose name is in Japanese.

When applications use Western fonts and display Japanese Kana and Kanji, the fonts do not look good. It seems to me that, by default, Ubuntu just assumes Chinese. Some Kanji look weird to me. For example, the "誤" in "誤解" or the "直" in "直接" do not look like the one used in Japan.

I mean, they look like this, if the application is using a Western font: enter image description here

If I set a Japanese font I like, they look like this: enter image description here

Is there any way to force Ubuntu to use a specific Japanese font when it is displaying Kana/Kanji in a Western font? Perhaps there is no way for the system to tell whether a specific text is Japanese or Chinese; but I do not read Chinese so I do not care if real Chinese texts are wrongly displayed in the Japanese font.

[Added in response to the comment]

Below is the output. I had tried to remove the Noto font series but they came back when I installed some applications. I also tried to remove fonts of languages I cannot read at all. Basically I just want Western European fonts (English, German, French, etc), Japanese fonts, and Korean fonts.

$ fc-match -s | head -15
DejaVuSans.ttf: "DejaVu Sans" "Book"
DejaVuSans-Bold.ttf: "DejaVu Sans" "Bold"
DejaVuSans-Oblique.ttf: "DejaVu Sans" "Oblique"
DejaVuSans-BoldOblique.ttf: "DejaVu Sans" "Bold Oblique"
n019003l.pfb: "Nimbus Sans L" "Regular"
DroidSansFallbackFull.ttf: "Droid Sans Fallback" "Regular"
NanumGothic.ttf: "NanumGothic" "Regular"
FreeSans.ttf: "FreeSans" "Regular"
FreeSansBold.ttf: "FreeSans" "Bold"
FreeMono.ttf: "FreeMono" "Regular"
FreeSerif.ttf: "FreeSerif" "Regular"
opens___.ttf: "OpenSymbol" "Regular"
DejaVuMathTeXGyre.ttf: "DejaVu Math TeX Gyre" "Regular"
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
DejaVuSerif.ttf: "DejaVu Serif" "Book"
(the end)

[Added]

I posted a question to a general Japanese Q&A site (which is not a technical web site). I asked if the "誤" and "直" in my first screenshot are used in Japan. I got two replies, and both of the Japanese persons said they were not used in Japan and they guessed those letters were simplified Chinese letters. But I think they are not simplified Chinese letters either, because I have seen that the left 言 part becomes a weird single line in simplified Chinese letters.

  • Which Ubuntu version? – Gunnar Hjalmarsson Nov 21 '16 at 16:29
  • The latest version, 16.10. – Damn Vegetables Nov 21 '16 at 16:48
  • Ok, then you have fonts-noto-cjk available, which actually gives precedence to Japanese by default. Have you tried to not specify the font explicitly in the applications? – Gunnar Hjalmarsson Nov 21 '16 at 16:53
  • There are many variations in the "Noto-CJK" fonts. I tried many of them, and all of them displayed those Kanji like the first picture. I did not set the system font to Noto. And frankly I think that is irrelevant to my situation. I need to deal with English/Japanese/Korean at the same time, so explicitly setting the system/all application fonts to a specific Japanese fonts would not work for me. I need to change the way how Ubuntu chooses the font for Japanese (Kana/Kanji), even when the application is using a non-Japanese font such as Times New Roman. – Damn Vegetables Nov 21 '16 at 17:12
  • I'm not talking about setting a specific Japanese font, I'm talking about not specifying it in the applications (if possible) and let fontconfig handle the precedence. Can you please run the command fc-match -s | head -15 and show us the output by editing your answer, so we get an idea of the fonts currently available on your system. – Gunnar Hjalmarsson Nov 21 '16 at 17:24
1

To make use of the MotoyaLMaru font, try to add a config file along these lines:

$ cat ~/.config/fontconfig/conf.d/10-japanese-preferred.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <alias>
        <family>sans-serif</family>
        <prefer>
            <family>MotoyaLMaru</family>
        </prefer>
    </alias>
</fontconfig>
  • Thank you for your support. I added this file (did not exist before) and rebooted. Now the file browser and the text editor shows Japanese Kanji and Kana in the font I wanted. I am yet to test more if this could cause any side effects on other languages or in other applications, but right now I am happy with this Japanese font. – Damn Vegetables Nov 22 '16 at 3:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.