5

When I set the album title of a song to be blank in RhythmBox then when I play the song the notification will show it as 'Song title by Artist' which is what I want. But every time I close and reopen RhythmBox it sets all blank album titles to what they previously were, in this case Unknown, so the notifications read 'Song title by Artist from Unknown' which looks gross. Is there a way to keep the album title blank without it resetting it to Unknown?

Edit: RhythmBox is version 3.0.2 running on Ubuntu 14.04 LTS

  • Edit your question with your Rhythmbox version. Found at Help > About – M. Becerra Dec 13 '16 at 11:39
  • it has been edited – cheesits456 Dec 13 '16 at 15:34
2
+50

I'm sorry to say you can't change that, it is a bug, and as you can see it's been reported several times since several past versions of Rhythmbox.

Reported at Launchpad, Bugzilla 1, Bugzilla 2 and Debian.

You can go to any of those sites to mark the bug affects you as well, and wait a response regarding any future patch solving it.

  • This is not an answer – cheesits456 Dec 13 '16 at 19:15
  • @ChristianF97 You are asking how to do X, I'm telling you that you can't do X because of a bug. Despite that, your question should be closed as its a bug that should be reported, therefore, off-topic. Flagged it because of that but as there's a bounty it cant be closed. – M. Becerra Dec 13 '16 at 19:25
  • 1
    My apologies, I misread a couple things – cheesits456 Dec 15 '16 at 21:44
  • 1
    Your answer was the most helpful for me, therefore you have been awarded the bounty. – cheesits456 Dec 15 '16 at 21:45
  • @ChristianF97 No problem, I'm sorry this wasn't the kind of answer expected – M. Becerra Dec 15 '16 at 21:50
1

Rhythmbox plays songs using a reference to the file , and it does store some information about the ID3 tags but that may not be your case for the album section.

What you can do is edit those tags directly on the song files. There are different options to do that, here you have some that run natively on linux and support mp3,mp4, FLAC and others:

  • EasyTAG allows a lot of editing options.
  • mid3v2 for the command line. You can get it with sudo apt-get install python-pip;sudo pip install mutagen
  • Picard cross-platform .

As requested, how to use mid3v2:

DESCRIPTION - from mutagen

mid3v2 is a Mutagen-based replacement for id3lib’s id3v2. It supports >ID3v2.4 and more frames; it also does not have the numerous bugs that plague >id3v2.

This program exists mostly for compatibility with programs that want to tag >files using id3v2. For a more usable interface, we recommend Ex Falso.

  • General syntax

mid3v2 [options] filename ...

In order to change album name use this option:

--album=ALBUM_NAME

Example: Go to the directory where the file is located and run

mid3v2 --album=Ubuntu Foosong.mp3

This will set the album of the song 'Foosong' to be 'Ubuntu'.

Source and more info for mid3v2 here


If even after setting the Album tag blank, Unknown appears on Rhythmbox, you can try to name the Album tag with an Arabian character, wich shouldnt be recognized and show a blank space instead. Get wichever you like the most from here.

  • Please make this answer more extensive - explain how to use the mid3v2 command – cheesits456 Dec 12 '16 at 20:49
  • @ChristianF97 Edited it! Hope it can help you better now. – M. Becerra Dec 12 '16 at 23:29
  • I've tried all those methods and they all do the same thing RhythmBox does - I can use them to make a blank album title but when RhythmBox reloads it sets them all back to unknown. Contrary to what you said, Arabian characters do show up, and even if they didn't the notification would say 'Song title by Artist from' which is almost more infuriating than saying 'from Unknown' – cheesits456 Dec 13 '16 at 3:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.