0

I normally switch between Chinese, Japanese, English an Spanish for typing. I installed the languages at language support, set ibus as the input method, installed input methods for Chinese (sougou, bopomofo, pinyin and sunpinyin) and restarted the computer. When I select another language other than English, the keyboard is still in English; for Spanish I can't type the ñ, and for Japanese and Chinese the text won't change into characters. Then I tried setting fcitx as the input method, but none of the languages are displayed if I want to switch between languages, only English. I'm using Ubuntu 16.10.

  • I do not know for other languages but for Spanish (French and other languages with accents or annotations on letters) you can add English (US, alternative international). With this you can just first press the key for the accent/annotation and right after the letter. For instance ~ and then n give you ñ. – Juan Antonio Nov 21 '16 at 13:08
  • I think you need provide more details, such as: Exactly which packages did you install, how do you switch input language, does the input source menu list all the languages you want to use. Also, please read this page if you haven't already. – Gunnar Hjalmarsson Nov 21 '16 at 13:39
  • You need some other packages ibus-anthy or fcitx-mozc for Japanese. After that, you need some configurations for each input method and engines, open ibus/fcitx setting, then Anthy/Mozc setting to type Japanese characters, so does Chinese. Some combinations stopped developing, e.g. ibus-mozc. They are no longer useful for new Ubuntu releases. – psw1747 Mar 9 '17 at 19:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.