1

I recently got a new Acer-spin laptop, it has pre-installed Windows 10. I have installed Dual-boot Ubuntu before, just never using UEFI (always BIOS). I want to Dual-boot with Ubuntu 14.04, however when I finished installing (via Install alongside option NOT "Something Else". But the computer boots directly to Windows 10. So I have checked various forums now and this is everything I have tried:

Disabled Secure Boot Disabled Fast Boot Tried Boot-repair Tried to boot from live usb Ubuntu and reinstall grub (however I was unable to keep up, when following error showed up "Cannot find EFI directory")

Any other suggestions??

  • Not sure about your model, but every Acer so far has needed user to set a supervisory password in UEFI and enable "trust" on .efi boot files in the ESP - efi system partition. But if no efi directory (ESP) then did you install in BIOS/CSM/Legacy boot mode? May be best to see details, you can run from Ubuntu live installer or any working install: Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info – oldfred Nov 21 '16 at 3:19
  • Did you install Ubuntu in UEFI mode? – Organic Marble Nov 21 '16 at 3:20
  • Just a guess, but you may be running into problems with the Windows (not firmware) Fast Startup and/or Hibernate features. See here and here, respectively, for information on how to disable these two features. – Rod Smith Nov 21 '16 at 15:22
2

I had forgotten about this post; anyhow, none of the usual answers worked for me. Instead there was an option in the UEFI menu that said "add option to UEFI boot" (or something along the lines of it) from there I was able to add the Grub menu. I hadn't seen this answer anywhere, I assume not many computers have it or simply don't require this option. Either way, thanks. I hope someone who comes across this finds it useful.

  • I'm thinking about buying this laptop. I will use ubuntu almost exclusively on it. Besides this issue are you relatively happy with it, or should I look elsewhere? – David O'Brien Jun 7 '17 at 17:43
  • @DavidO'Brien It has worked efficiently so far, I use Ubuntu on it most of the time. Windows 10 is just in case I come across a program I cannot use (or don't have the time to find out how to) in Ubuntu. But the – Joshua Cruz Jun 8 '17 at 18:46
  • @DavidO'Brien So no, no issues. Feel free to ask for help if you need help with the Dual Boot. – Joshua Cruz Jun 8 '17 at 18:48
1

To help others who have the same issue on the same Acer model (mine is Spin SP513), I provide procedures I figured out to do a dual boot on Ubuntu/Windows 10:

  1. Boot into BIOS by press F2 during boot-up stage.
  2. Set up the supervisor password on security tab if you have not done it yet. If you do not set up supervisor password, you are not able to modify the "Secure boot" and couple other options which is required for dual boot.
  3. Switch to Boot tab and disable the secure boot option(you need set supervisor password first).
  4. Set the boot sequence, so the USB stick is the first one in the list.
  5. Insert the boot-able Ubuntu USB stick into USB port then save/exit the BIOS. The computer reboots and finish the installation of Ubuntu on free HD space.
  6. Do not be surprise that the laptop boots into windows directly after installation of Ubuntu. We need change the boot sequence to load items indicated by grub efi files.
  7. Boot into BIOS by press F2 again during boot time.
  8. On Boot tab, now enable the secure boot again, this will let you add boot list on next step.
  9. Go to Security tab, now you can select UEFI option to add extra efi options. Select the file under EFI partitions.
  10. switch back to Boot tab, you will see an extra item on the end of boot list, the name is awkward, yes, on my case, it is "EFI File boot 0 : yes" which is actually Ubuntu's grub entrance. Move that item to the top (as first item to boot to). This item has both Windows and Ubuntu entrances which does the dual boot function.
  11. Save changes and exit Bios.
  12. Cheer (took me half of a day to figure this out).
0

If you've disabled fast boot, make sure that - when you click on the power icon to restart the PC - you hold down the SHIFT key as you click on the icon and select the restart option. This should take you to a blue screen with white text and graphics. Look for the "Devices" option and select that, you should have an option to boot to Ubuntu under there.

Source: Experience

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.