0

I have been trying to get evolution to open/run have tried in terminal with the following result. any advice on how to fix it ?

david@david:~$ sudo evolution %U
[sudo] password for david: 
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
libEGL warning: DRI2: failed to authenticate

(evolution:2957): GLib-ERROR **: /build/glib2.0-8EA4QF/glib2.0-2.48.1/./glib/gmem.c:100: failed to allocate 3748491972 bytes
Trace/breakpoint trap (core dumped)
david@david:~$ 
2
  • 3
    Never run applications exposed to the www like browsers or email applications as root (or with sudo) please. That's a serious security threat. – Byte Commander Nov 20 '16 at 23:16
  • 1
    Which, btw, is also the source of your problem: the root user cannot access your desktop/screen (display ":0" belongs to your logged-in user, so the "failed to authenticate" was to be expected). As @ByteCommander pointed out: root/sudo is for system maintenance, not for running user applications. – Izzy Nov 21 '16 at 17:35
0

I had this problem too (Evolution offline after 16.04 update), but the suggestion in https://help.gnome.org/users/evolution/3.16/offline.html.en , ie. to run

GIO_USE_NETWORK_MONITOR=base evolution

in a terminal window, with Evolution not running, worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.