Hello and sorry in advance if this is duplicate; I've read all other posts and still can't figure out how to fix this.

I have a Lenovo T540P with Ubuntu 16.04 LTS installed. I use this laptop every day and have never had issues with Ubuntu. Yesterday, I restarted my laptop (it usually stays on for months at a time as I am always working on it, only suspending overnight) and now it won't boot.

The screen says

/dev/sda1: clean, 338085/30220288 files, 8546668/120849408 blocks

I've let it sit for like half an hour now and it just hangs. I can tty to F2 and login, but I don't know how to diagnose the problem.

How do I resolve this issue?

The solution that worked for me was to reinstall lightdm. TTY and execute the following:

sudo service killall lightdm

apt-get install --reinstall lightdm

sudo reboot

I don't know why this worked, but it may help others ...

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.