4

I've been reading this. Apparently I would gain root access if I hold down enter (somewhere) for 70 seconds. I tried it on a password prompt but it gave me like 3 attempts and stopped. I tried it on a tty but it didn't work also. Am I not vulnerable or am I doing it wrong?

3

See the security website from Canonical on this. All releases have a "needed" so there is no fix yet for them.

So if you match the conditions for this bug you can affected. For 1 you need to be using Linux Unified Key Setup (LUKS), cryptsetup. So your partition needs to be using encryption. If you do not ... you do not have a problem. (More info at hmarco.org)

The fix is rather easy, just run this commands to add panic parameter to your boot configuration:

sudo sed -i 's/GRUB_CMDLINE_LINUX_DEFAULT="/GRUB_CMDLINE_LINUX_DEFAULT="panic=5 /' /etc/default/grub grub-install
sudo grub-install

panic=5 to your options preventing this problem. This is the number of seconds you want to initiate the reboot after the panic. Adding the panic parameter to the kernel entry in the grub configuration will prevent a shell.

  • Well, if you're not using encryption, you do have 99+ problems, but this ain't one. :P – muru Nov 20 '16 at 16:48
  • During installation it asks whether I'd want the home folder encrypted, is that the encryption you're talking about? – Mina Michael Nov 20 '16 at 16:51
  • Nope. It is about encryption for your boot disk. – Rinzwind Nov 20 '16 at 16:51
  • okay, how do I know whether it's encrypted? XD – Mina Michael Nov 20 '16 at 16:52
  • 2
    If you don't know it is NOT encrypted ;-) – Rinzwind Nov 20 '16 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.