1

I'm trying to install python3-pip but when I do

sudo apt-get install python3-pip

I get I have dependencies problems with python3-dev, then I do

sudo apt-get install python3-dev

and this goes on and on until I get to a dependency which the system claims to be already installed (libpython3.5)

So how can I solve this and properly install pip3?

This is the full output when I do try to install python3-pip:

    Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 python3-pip : Depende: python-pip-whl (= 8.1.1-2) pero 8.1.1-2ubuntu0.2 va a ser instalado
               Recomienda: python3-dev (>= 3.2) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

And this is the one I get with python3-dev

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 python3-dev : Depende: libpython3-dev (= 3.5.1-3) pero no va a instalarse
               Depende: python3.5-dev (>= 3.5.1-2~) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

The rest of outputs for the rest of dependencies are just the same.

I don't know if the problem is in the last line "E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos. which means "The problems couldn't be solved, you've held broken packages".

Ubuntu version is 16.04.01LTS

Help please :/

  • Ubuntu version? :) Can you also try sudo apt install -f and sudo apt install python3-pip -f? – Ads20000 Nov 20 '16 at 14:00
  • version is 16.04.01LTS, the same happens if I use those commands – Ulises CT Nov 20 '16 at 14:11
  • sorry, might be sudo apt-get -f install, also try dpkg-reconfigure --all – Ads20000 Nov 20 '16 at 14:23
  • yet another command: sudo aptitude -f install Also you're fully up-to-date with sudo apt update ; sudo apt upgrade right? – Ads20000 Nov 20 '16 at 14:24
  • you could also try sudo apt-get purge python3 ; sudo apt install python3-pip. Are you using PPAs? Disable them and downgrade your packages to the repository versions using sudo ppa-purge repository_name for each repository, then try installing python3-pip again (using PPAs is always risky because they mess with dependencies). It may be that you'll have to reinstall Ubuntu (backup first!) because you've messed something up somewhere, this is why Snappy is so good - it avoids this problem of dependency hell entirely. – Ads20000 Nov 20 '16 at 14:31
1

Run the command sudo aptitude -f install

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.