4

I had been using firefox 49 on Ubuntu 14.04, 64-bit, with the user agent solution found here, and all was well: Now that I have Firefox 49 or higher, how do I watch Netflix?

Then firefox 50 came along and now I get this message at the top of the browser window:

"libavcodec may be vulnerable or is not supported and should be updated to play video"

And netflix tells me:

"Whoops, something went wrong... Netflix Video Player Unavailable We're having trouble playing Netflix on your browser. Please make sure you are on an official version of Chrome.

Error Code: M7355-1204"

I have tried searching for the libvacodec error and for firefox 50 + netflix. Anyone have a solution to this?

  • 2
    See here for the fix: superuser.com/questions/1137029/… – Organic Marble Nov 20 '16 at 14:13
  • I really gave up netflix on firefox. I have chrome just for that. – Vitor Abella Nov 22 '16 at 16:04
  • Vitor Abella, its working well for me across many machines. All i needed was the user agent fix. see below – kosf Jan 2 '17 at 21:27
2

Ubuntu Modifications 3.2 is causing the problem! If you are using Ubuntu (any flavor) and are using Firefox as a search engine go into Add-ons manager then into Extensions and disable or remove Ubuntu Modifications 3.2! Restart Firefox ------ Linux Is Great :-)

  • Hi, good news, the problem seems to have been fixed so no need to disable ubuntu modifications. thanks though. – kosf Jan 2 '17 at 19:10
2

Update + solution: the problem was fixed so SKIP STEP 1.

if you want to just get netflix running by changing the User Agent of the browser follow steps 2-3

1) Update Libvacodec https://superuser.com/questions/1137029/libavcodec-may-be-vulnerable-message-in-firefox

2) Install UAControl* (seems like best user agent switcher because you can set the user agent for just 1 website like www.netflix.com) https://addons.mozilla.org/en-us/firefox/addon/uacontrol/?src=search

3) Open "UAcontrol options..." -> click "add site" -> for "site:" put www.netflix.com

-> paste this code in "custom" text box:

Linux / Chrome 53: Mozilla/5.0 (X11; Ubuntu; Linux x86_64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/53.0.2785.34 Safari/537.36

*Because netflix are mean and don't care about ubuntu users and force us to fool them into thinking we are using a different operating system/browser combo.

  • 1
    Thanks to users Organic Marble and GizmoChicken over here for the user agent code line: askubuntu.com/a/828305/609155 – kosf Dec 6 '16 at 0:05
  • Can anyone confirm if this is working on 32-bit 14.04? – kosf Jan 2 '17 at 19:24
  • It worked on 32 bit in FF 49. Seems to not work in 50. – Organic Marble Jan 17 '17 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.