0

I have bluetooth headphones Urbanears plattan adv wireless and Ubuntu mate installed on my computer.

I searched and tried nearly every suggested solution. Last night after removing and re installing stuff like blueman and pavu control I got the headphones to work. I thought it will work from now on but today it is not working again :(

I can connect the device to computer but only as a headset not as audio sink, and pavu control lets me choose my headphone as the output device but the volume level stops at that point and there is no sound at the headphones.

Any suggestions ?

  • Check the bug report as there may be a work around that helps – Jeremy31 Nov 19 '16 at 12:04
  • Yes @Jeremy31 the solution or so called "workaround" seems to work for me too :( but it's really a pain in ... Is there any way that I can automate that process ? I will start looking for a way – Cynapsis Nov 19 '16 at 23:24
  • You might be able to find a way to use the work around in a script that is executed at startup. I tried the a2dp.py once and it didn't work for me but the bug has gotten the attention of Luke Yelavich and I would say a fix is in progress now – Jeremy31 Nov 20 '16 at 0:31
  • Maybe not at startup because the workaround is supposed to be done after you connect the headphones so you should connect the headphones and then run the script may be that will work but I think it's not that hard to do manually :) – Cynapsis Nov 20 '16 at 21:25
1

Tried to get my headphones to work but seems there are just too many issues with Bluetooth.

Got them to pair (sometimes). fails to connect on reboot.

Then once paired the option to select the headphones as an audio output is not there. This might be what they call a card which is not getting loaded.

Tried using the blueman (Bluetooth manager). This provided the "audio sink" option which allowed me to select a sink? Then in the audio applet I could then see a headphones option. This then worked until I rebooted. Unfortunately I was not able to replicate this success again.

This script seems to be addressing many connectivity issues not being addressed in the connectivity applets. These people seem to know what is going on.

https://gist.github.com/pylover/d68be364adac5f946887b85e6ed6e7ae

There are just too many hacks attempting to fix this stuff without any real clear direction. Modules loaded not loaded / pairing / cards / pins and authentication.

Not even sure where they are in fixing any of these issues with the large number of bugs listed.


another attempt got the headphones working. not sure if they will persist after reboots without messing around with Bluetooth manager.

In Bluetooth manager..

  • delete your device from Bluetooth manager
  • disable Bluetooth service
  • delete any pairing info stored in headphones by resetting them
  • enable Bluetooth service
  • find device in the list and choose setup
  • select pair now and then headset options
  • prompt for access to phone book? must accept this.
  • now go into audio settings and choose the new headphone output.

This must be an authentication issue as I hadn't seen the "access phonebook" prompt before. saying yes to this completed the setup process.

Also there is the synonymous use of "headset" and "headphones" here and there. "headphone" is an improper description of these devices and should be avoided.

  • got them to work by... – user2647293 Nov 22 '16 at 19:20
  • * disable bluetooth – user2647293 Nov 22 '16 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.