0

I am running Ubuntu Server 16.04 Xenial on my mini itx board with a Nvidia GT218-ION videocard. I installed kodi and xinit but I seem to mis the correct Nvidia drivers, nvidia-304 (current) dont work with the latest version of xinit as it seems.

Nouveau drivers gives me: List of video drivers: nouveau modesetting No devices to configure. Configuration failed. (EE) Server terminated with error (2). Closing log file.

The nvidia-367 seems to work but also installs gnome which i dont want.

I did install the nvidia driver from their website now but i got this error: [ 2922.845] (II) LoadModule: "nvidia" [ 2922.846] (WW) Warning, couldn't open module nvidia [ 2922.846] (II) UnloadModule: "nvidia" [ 2922.846] (II) Unloading nvidia [ 2922.846] (EE) Failed to load module "nvidia" (module does not exist, 0)

when i try to install nvidia-340 through the apt repo i get this: pastebin.com/YaJhq4m5 as you can see it wants to install gnome and unity packages

  • The nvidia-367 seems to work but also installs gnome ????? No, installing a graphics drivers does not install a desktop environment. Besides, 304 is old, not current, and doesn't support ION. According to Nvidia you need 340 (and only this version): nvidia.com/download/driverResults.aspx/107868/en-us – user589808 Nov 19 '16 at 10:48
  • Yes I installed the 340 driver from the nvidia website but I get this error now: [ 2922.845] (II) LoadModule: "nvidia" [ 2922.846] (WW) Warning, couldn't open module nvidia [ 2922.846] (II) UnloadModule: "nvidia" [ 2922.846] (II) Unloading nvidia [ 2922.846] (EE) Failed to load module "nvidia" (module does not exist, 0) – Alex1602 Nov 19 '16 at 11:03
  • You need to remove all previous versions before installing a new one: sudo apt purge nvidia. Reboot. Then you should be able to install the drivers already in the official repos: sudo apt install nvidia-340. – user589808 Nov 19 '16 at 11:06
  • when i try to install nvidia-340 through the apt repo i get this: pastebin.com/YaJhq4m5 as you can see it wants to install gnome – Alex1602 Nov 19 '16 at 11:06
  • Please edit and add all that information to your question, not just as a comment. – user589808 Nov 19 '16 at 11:11
0

I installed the nvidia-340 from the repository and after that removed unity-greeting.

after a apt-get autoremove also all the other gui stuff got removed

Its working for now but it stays weird that a graphics driver installs unity and gnome stuff

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.