2

First of all I m a newbie to ubuntu and recently installed 16.10. Then when i tried to connect to the internet my usb dongle doesn't show up.

I tried everything, googled many times. I tried adding a new connection in the regular way by going to wifi sign in top right corner and etc etc... But nothing worked.

In my dongle there is a folder named Linux and there are few files like install , 7zr , Mobile partner.dat and also a readme.txt. I ve done every step of the instructions there is in the readme.

It says login as root (sudo) and type tar (some 4 letters) Linux_install.tar.bz2.

When i execute this code terminal shows there is no files or events(something similar to that.).

Then I looked to see if my device is recognized by the OS using lsusb And it shows that USB Modem Huawei Technology.inc is recognized as a mass storage device.

My Dongle: Huawei Mobile Broadband E303


output of lsusb:

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 004: ID 10f1:1a4f Importek 

Bus 001 Device 006: ID 0930:0220 Toshiba Corp. 

Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 003 Device 004: ID 12d1:14fe Huawei Technologies Co., Ltd. Modem (Mass Storage Mode)

Bus 003 Device 003: ID 09da:0260 A4Tech Co., Ltd. KV-300H Isolation Keyboard

Bus 003 Device 002: ID 09da:000a A4Tech Co., Ltd. Optical Mouse Opto 510D / 
OP-620D

Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • iwconfig command show any wireless interface? – SuB Nov 19 '16 at 12:03
  • #SuB No it said no wireless extensions. – ThePilot Nov 19 '16 at 15:01
  • You should install the correct driver. tar command extracts file inside an tarball archive. After that you should run something like make or cmake or ./configure to compile and install the driver. – SuB Nov 19 '16 at 16:49
  • Please put the output of lsusb. It lets me now which chipset your dongle uses, so i can help you how to install the correct driver. – SuB Nov 19 '16 at 16:50
  • when I tried to extract using 'tar jxvf linux_install.tar.bz2' it said – ThePilot Nov 20 '16 at 0:25
2

This is probably caused by a bug in the usb-modeswitch package. A fixed version of usb-modeswitch is currently available in my PPA.

Open a terminal window and run these commands:

sudo add-apt-repository ppa:gunnarhj/misc
sudo apt update
sudo apt install usb-modeswitch

Then reboot. Now - hopefully - all you need to do is inserting the dongle, and it should be detected automatically.

  • I did the above and restarted and inserted the dongle again and Now there is a msg called unable to mount the cd rom: In the Disks or home my dongle is not detected. – ThePilot Nov 21 '16 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.