1

Pre-question information:

I have:

  • ASUS P8 Z77-V LX Motherboard
    (running BIOS Setup: ASUS UEFI BIOS Utility v. 1201 x64)
  • 2x Empty HDDs:
    • 1x 3TB
    • 1x 1TB
  • A lot of time

Aim

I'm wanting to Dual boot Windows 10 with Ubuntu Studio 16.04 in UEFI mode (Legacy BIOS is out of the question). I have installation discs of both.

What I've done so far

With no HDDs attached, booted BIOS and disabled CSM (to force UEFI mode).

I plugged in and, using GPT, partitioned & formatted my 3TB HDD then installed Windows 10. I can tell it was successful in installing Windows 10 in UEFI mode as when I run msconfig32 it states the BIOS mode is UEFI.

I then shutdown my PC, unplugged my 3TB, plugged in my 1TB, put in my Ubuntu Studio 16.04 Live disc and booted.
For the sake of providing information if it's related, to successfully install Ubuntu studio I had to:

  1. Edit the menu option "Install Ubuntu Studio" to include nomodeset and nolapic before running to ensure UI actually loaded.
  2. Disable Ethernet Network connection on the installation setup desktop.
  3. Leave "Download updates" and "Install 3rd Party Applications" unchecked.

Steps 2 and 3 were required due a bug in the installation process where the "Force UEFI mode" warning box would not close on clicking Continue. For some reason, performing steps 2 and 3 nullified this issue.

I formatted my 1TB drive using GPT and making the following partitions:

  • 1000MB EFI System Partition (ESP) (I know 1GB is over kill, but space isn't a problem for me)
  • 128000MB Ext4 partition mounting at point /
  • 16000MB Swap space
  • All remaining space (~800GB) as an Ext4 partition mounting at point /home

The installation process seemed to be successful, however upon rebooting my PC, my motherboard/firmware refuses to load Ubuntu studio and states:

The current BIOS setting do not fully support the boot device. Click OK to enter the BIOS Setup. Go to Advanced > Boot > CSM Parameters, and adjust the CSM (Compatibility Support Module) settings to enable the boot device.

I don't want to do that.
I tried it (enabling CSM) and it booted Ubuntu Studio...into BIOS mode. I check this by performing:

$ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

and it stated BIOS.
I don't get why it's only booting to BIOS mode if I installed it in UEFI mode, clicked Continue on the "Force UEFI mode" warning, and it has a ESP which when I booted (in BIOS mode) stated that it mounted at point /boot/efi and had the boot flag.

I have shutdown and disabled CSM, disabled "Fast Boot" after I realised that it was enabled, checked that "Secure Boot" is disabled (it is) and now I'm stuck as to what to do next.
What should I do?


Some quick proof I've done things correctly:

Ubuntu is partitioned correctly: enter image description here

Warning message on startup: enter image description here

Boot Priority doesn't even recognise the drive: enter image description here

  • It sounds like that "bug in the installation process" is keeping you from installing in UEFI mode. Did you check that you actually booted the live disc in UEFI mode? – Organic Marble Nov 18 '16 at 19:43
  • @OrganicMarble Possibly...Thing is, the bug in the installation affected the popup that allows me to continue to force UEFI mode. And if ensuring that there is no network connection and that I'm not installing 3rd party applications and downloading updates, how does that affect my machine not booting to UEFI mode when it's been told to force it and it hasn't received any package updates? – Harmelodic Nov 18 '16 at 19:47
  • What model Asus motherboard. With my Asus-AR, I could only get it to boot in UEFI mode with UEFI only. The setting for UEFI & BIOS, UEFI first would only boot in BIOS mode. I also made a variety of other UEFI settings.askubuntu.com/questions/503168/… and:askubuntu.com/questions/554735/good-z97-motherboard-for-ubuntu Have you installed newest UEFI from Asus? – oldfred Nov 18 '16 at 21:19
  • @oldfred I've updated the answer with the model of the motherboard. Aside from when I tested the Ubuntu installation with CSM enabled, I've had it disabled since the beginning of the process, as I say in my answer. Meaning that it's fixed towards UEFI and won't support Legacy BIOS as I don't want to run Legacy BIOS. – Harmelodic Nov 18 '16 at 22:24
1

I then shutdown my PC, unplugged my 3TB, plugged in my 1TB, put in my Ubuntu Studio 16.04 Live disc and booted.

This isn't related to the problem you're experiencing, but unplugging disks as you've done, although a useful trick in BIOS, is counter-productive in EFI. The trouble is that many EFIs delete EFI boot manager entries when they detect that they're missing. Thus, when you unplugged the Windows disk and installed Ubuntu on another disk, it's possible your EFI deleted the Windows boot manager entry, which could make it difficult to boot back into Windows again. If you rely on a boot manager like GRUB or rEFInd to manage the boot process, they'll work around this problem -- but in the case of GRUB, you'll need to reconfigure it (sudo update-grub) with both disks plugged in. Also, if you ever try the reverse (unplugging the Ubuntu disk), your firmware may delete the GRUB boot entry, which will then make it impossible to boot Ubuntu without performing additional repairs.

Note also that Windows usually installs a copy of its boot loader as EFI/BOOT/bootx64.efi, which is the fallback filename. Some EFIs also treat the standard Windows EFI/Microsoft/Boot/bootmgfw.efi entry as a sort of fallback entry. Thus, Windows might boot even with its boot entry missing. The same is not true of Ubuntu and its GRUB, though, so once you get things working, you should be extra careful to not unplug the Ubuntu disk if you rely on GRUB as a boot manager.

Steps 2 and 3 were required due a bug in the installation process where the "Force UEFI mode" warning box would not close on clicking Continue.

This sounds like bug #1418706. (I think there may be another report of this bug, too, but I can't quite find it....) Rather than the solution you used, I recommend you put some partitions on the disk before running the installer. You've gotten past this issue, though, so it's not really the problem....

I tried it (enabling CSM) and it booted Ubuntu Studio...into BIOS mode.

This sounds like there's a working BIOS-mode boot loader installed on your disk, which in turn implies that you installed in BIOS/CSM/legacy mode, despite your best efforts to the contrary. Unfortunately, there's no standardization in how the CSM is controlled, and on some computers, it's easy to leave it enabled when you think it's disabled. (I've dealt with some servers that are complete nightmares in that respect -- they've got a bazillion options related to the CSM, and setting one of them incorrectly provides a path for BIOS-mode booting.) You may want to check my page on the CSM for more on this subject. Also, to get more information, you might try running the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here for interpretation.

One way to be reasonably sure you boot in EFI mode is to use my rEFInd boot manager on a USB flash drive or CD-R. With its default options on a UEFI-based PC, rEFInd boots only in EFI mode, so if you can boot Ubuntu via rEFInd, it will be in EFI mode. (On Macs, though, rEFInd can boot Ubuntu in either BIOS mode or EFI mode, depending on what boot loaders and filesystems are in use.) You can then install GRUB manually or install rEFInd (via its PPA or Debian package) to keep booting in EFI mode.

  • This isn't related to the problem you're experiencing, but unplugging disks as you've done, although a useful trick in BIOS, is counter-productive in EFI. This was my exact problem it turns out! I reconnected my Windows Drive and I got an option to install "Alongside Windows Boot Loader" when reinstalling Ubuntu Studio. I clicked that option and the install went okay. It then restarted and booted into Grub2 first and then loaded up! I had to faff with the Grub2 menu item to include nomodeset and then mess with nVidia driver once it loaded. But it worked! In UEFI mode! Thanks :D – Harmelodic Nov 22 '16 at 0:09
  • Weird. My guess is that the firmware was getting confused by the disappearance of the Windows option. It SHOULDN'T do that, but EFI is pretty complex, so there are lots of ways for bizarre bugs to crop up in just one implementation. I'm glad you got it fixed! – Rod Smith Nov 22 '16 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.