I have no idea what's going on, or how to fix this. When I browse to some sites like Amazon or Bandcamp, I'm getting one of those Your connection is not private errors in chromium. What's weird about this is when I switch to using FireFox I can load those sites just fine (and the SSL certs are accepted).

I'm also running chromium on another Ubuntu instance (same versions) and I'm not getting these errors. Only one this one machine.


Have you tried updating & upgrading? There are a number of issues circulating regarding SSL certificate errors on certain versions of Chrom* browsers.

sudo apt-get update && sudo apt-get upgrade

and then reboot. This resolved certificate errors for me in Chromium.

  • That fixed it. I have no idea why it happened. Usually apt checks for updates every two days for me. – Benjamin Nov 18 '16 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.