0

I recently upgraded my dedicated server to ubuntu 16.04 LTS (for somes reasons). I don't know why, but when I started my server, nothing happened (no ping response).

With my host, I can boot on a live cd image (ubuntu 12.04) to recorvery my server. So I mounted my partitions to do a chroot session and I navigated to my /var/log folder. In this folder, there is no news logs (like "boot.log" or "syslog" written when I start my server with Ubuntu 16.04. It's like the server don't boot. Maybe a Grub Config Bug ?

Ps: I recently had a problem with my image "/boot/vmlinuz-4.4.0-47-generic" (image was missing when I tried to apt-get -f upgrade) but I reinstalled a new one with apt-get, My kernel version :

Linux 62-210-243-90 3.13.0-32-generic #57~precise1-Ubuntu SMP Tue Jul 15 03:51:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Here is my Grub configuration :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="console=ttyS1,9600 BOOTIF=01-e8-9a-8f-22-d9-61"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Thanks for your help, I know there is not enought informations, I don't know what's happening (And sorry for my bad english, I'm french).

  • As it says: Run sudo update-grub from the terminal of a live disk. – Muaad ElSharif Nov 18 '16 at 16:09
  • Ok, It found the kernel : root@62-210-243-90:/boot# sudo update-grub sudo: impossible de déterminer le nom de l'hôte 62-210-243-90 Searching for GRUB installation directory ... found: /boot/grub Searching for default file ... found: /boot/grub/default Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst Searching for splash image ... none found, skipping ... Found kernel: /vmlinuz-4.4.0-47-generic Found kernel: /vmlinuz-4.4.0-47-generic Updating /boot/grub/menu.lst ... done – Simon Et la famille Nov 18 '16 at 16:10
  • Reboot and see if it boots properly or not from the disk, not the live disk. – Muaad ElSharif Nov 18 '16 at 16:12
  • It can't boot. No ping response from the server. I reboot with the livecd – Simon Et la famille Nov 18 '16 at 16:26
  • There is no new logs. I'm in chroot again – Simon Et la famille Nov 18 '16 at 16:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.