9

I just got a brand new Dell XPS 13 9360 and replaced Windows with Ubuntu 16.04.1. Everything seems to work out of the box, except for few issues with video output to external monitor.

I bought two adapters from Aukey: USB-C to VGA and USB-C to HDMI. The first one is working flawlessly, but HDMI one has few issues.

My usual monitor is a 24" FullHD Samsung TV monitor: when I connect it through the adapter, audio is working fine but it looks like that colors are rendered with a 16-bit palette, thus making it unusable (I tested the adapter on Windows before wiping it and it works correctly).

I tried on another Samsung TV monitor with the same issue.

I tried also on a Toshiba TV and it works correctly all the time, so there must be some issues specific to Samsung displays and Ubuntu when using USB-C adapters (the same display had no issues with my previous computer running Ubuntu).

The only workaround I could find is to turn off Samsung TV monitor, connect it to my XPS and then turn it on: in this case it works correctly. But after unplugging, if I want to plug it again I have to turn monitor off and on again.

For the moment I can live with this, but I was wondering if anyone had the same problem and found a definitive solution.

  • Some TV User Guides actually state devices have to be turned on and off in specific order. Perhaps your manual states this? – WinEunuuchs2Unix Nov 18 '16 at 13:39
  • I checked the manual but it does not state anything about this. Anyway the problem only happens with Linux, when I use the same adapter on Windows everything works as expected. – Igor Saggese Nov 20 '16 at 18:31
  • When I tried to set up Ubuntu dual boot, I couldn't see any devices in the setup drives list. Did you have the same issue? Could you write up a guide to installing Ubuntu on the 9360? – Codesleuth Nov 28 '16 at 8:03
  • 1
    In order to install Ubuntu on the XPS13 you have to change SATA mode in BIOS from "Raid on" to "AHCI". Be careful that if you want to keep Windows, your current installation won't boot after you change the mode. You can either reinstall it after switching to AHCI or search online for a workaround. Someone says that if you boot in safe mode once after mode change Windows repairs itself and after reboot it will work normally. – Igor Saggese Nov 29 '16 at 20:35
  • Ubuntu 16.04 installed OK for me last month with SATA set RAID. This was on Windows 10 laptop with M.2 NVMe gen 3.0 x 4 SSD. – WinEunuuchs2Unix Nov 14 '17 at 12:44
4

With the Kernel 4.13 this issue is fixed for me.

Downloading and Installing for X64

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.13/linux-headers-4.13.0-041300_4.13.0-041300.201709031731_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.13/linux-headers-4.13.0-041300-generic_4.13.0-041300.201709031731_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.13/linux-image-4.13.0-041300-generic_4.13.0-041300.201709031731_amd64.deb

Installing the packages

sudo dpkg -i *.deb

Now just reboot and enjoy using your USB-C to HDMI adapter.

Reference : https://en.cristiantala.cl/fixing-ubuntu-usb-c-to-hdmi-dell-da200/

|improve this answer|||||
  • This worked to give me a 1080 output. Can't get any better resolution than that. My monitor supports 2560x1440. – Sudipta Basak Oct 16 '17 at 6:58
3

For me the workaraund is setting the audio to hdmi port, as soon as I do that colours on the external monitor become correct.

|improve this answer|||||
1

You can also try lowering the resolution of the second display. In my case, only after setting it down to 1080x720, can the usbc-to-hdmi output the display correctly.

My laptop Alienware 13 R2 and my adapter is DA200. Although not the same model with you, I guess it may still work since they are both produced by Dell. My system is Ubuntu 16.04.02 with Kernel 4.8.

|improve this answer|||||
  • This worked for me in kernel 4.10, but is not really "pretty". – CTala Sep 11 '17 at 7:03
  • @CTala yeah kind of disappointing. – fzheng Sep 13 '17 at 4:14
1

Here's a work around that restored normal picture for me. (If laptop screen is still operational it's very easy to try, but I have carried out some of these steps with the dysfunctional HDMI screen.)

  1. On your laptop click on the System Menu and select System Settings (The System Menu is the right most menu icon on the menu bar at the top of the screen; an iconic portmanteau of a Power Symbol and a Settings Cog Symbol)
  2. Under Hardware, select Displays
  3. Click on the offending display in the "Display Map"
  4. Below the "Display Map" there is a toggle beside the "Name of the Screen" you've just selected, toggle it to the Off position
  5. Click Apply the changes
  6. When prompted to do so, click on Restore previous configuration.
|improve this answer|||||
  • tried this, but it doesn't work – fedecupe Sep 30 '17 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.