0

while running sudo apt-get upgrade, I stumbled this problem:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 php5.6-fpm : Depends: php5.6-common (= 5.6.26-2+deb.sury.org~precise+1) but 5.6.28-1+deb.sury.org~precise+1 is installed
E: Unmet dependencies. Try using -f.

then after I do the suggestion by running sudo apt-get -f install, the new error message shows:

dpkg: dependency problems prevent configuration of php5.6-fpm:
 php5.6-fpm depends on php5.6-common (= 5.6.26-2+deb.sury.org~precise+1); however:
  Version of php5.6-common on system is 5.6.28-1+deb.sury.org~precise+1.
dpkg: error processing php5.6-fpm (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 php5.6-fpm
E: Sub-process /usr/bin/dpkg returned an error code (1)

I could not remove php5.6-fpm either because it also return Sub-process /usr/bin/dpkg returned an error code (1)

It seems the php5.6-fpm has different dependencies but cannot upgraded or removed because there is a configuration missing

1

A way to meet all required dependencies, is to install the lamp package by running the command below (including the ^ symbol)

sudo apt-get install lamp-server^

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.