6

I have installed Ubuntu 16.04.1 alongside windows 10, everything works perfect unless gnu grub menu 2.0.2 takes too long to boot, there is somewhere 15-20 sec black screen till purple grub menu shows up.

It is ASUS k501ux laptop with PCIE SSD and it always boot very fast. it is loading windows in 13 sec and Ubuntu in 8 sec but that grub menu takes too long. sometimes it loads perfectly as soon as I turn it on but mostly that's not case.

Otherwise both Ubuntu and Windows load pretty quickly after I choose it from Gnu grub menu, problem is loading time of gnu grub menu itself.

  • I got the very same problem, never resolved, with a triple boot Win/Ubuntu/Kali on a System76 Serval WS. I also tried to switch from Ubuntu Grub to Kali Grub the result doesn't change. It seems an issue related to bios or motherboard. – MKay Nov 18 '16 at 9:50
  • 1
    Just checking in to see what if anything has solved this problem? – WinEunuuchs2Unix Nov 25 '16 at 12:37
  • @WinEunuuchs2Unix nope i could not be able to find this out so i ended up by uninstalling ubuntu. I know there would be solution but I am so lazy doing this because there is so many things I did to get it worked corectly and i found out i had to do more. thanks for your replay, I appreciate this – Giorgi Khmaladze Dec 7 '16 at 7:46
3

To see what grub is doing while it's loading the kernel image and booting up Ubuntu you need to remove the splash screen and enable messaging. Open the terminal and use the command gksu gedit /etc/default/grub and search for this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vt.handoff=7 kaslr"

Change the line to look like this:

GRUB_CMDLINE_LINUX_DEFAULT="vt.handoff=7 kaslr"

Leave the other parameters alone (which probably don't look like mine). The important thing is to remove "quiet" and "splash" parameters.

Save the file and then use:

sudo update-grub

Now reboot your computer and watch for messages that pause for a long time. After getting a message that pauses for a long time you can review the log file using:

gedit /var/log/syslog

Additionally the time for all services loaded during boot can be reviewed using:

systemd-analyze blame

After getting specifics of what module(s) is/are slowing down your boot you can ask pointed question(s) about it/them

  • When I did this it disabled the splash screen from after the grub loaded, not before? – Rabbit Nov 24 '18 at 14:14
0

Well our problems may have been caused by something completely different but I'll tell you what I did to fix it for me anyway.

Firstly, for me it was the bios's fault, not grub.

I have a HP bios. (And ubuntu 18.04, which shouldn't be relevant)

I tried changing the boot order, I tried every boot option within reason (and that would have worked but the option I needed wasn't on the list, which was to boot straight from the "netbook hard drive".)

In the end I had to enable legacy boot for that to be an option, and then I went with the default legacy boot settings (instead of "hybrid") and lo and behold grub now pops up in about 1 second instead of 15.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.