This is the second time this has happened. I have disabled mouse acceleration on Ubuntu by following these instructions.

Immediately after that I tried to log out but the system got hung at the fsck screen, so after about 5 mins I force-shutdown the system and when turning it on again Ubuntu got stuck on the fsck screen and won't get past that!

I have tried using a live USB to both delete the file that I created and also run fsck on the sda6 partition and it says everything is OK. Don't really know what to do now. This is what it looks like:

This is what it looks like

  • Follow the instructions for using nomodeset at askubuntu.com/questions/162075/… and then make sure that you have the correct/newest video drivers installed.
    – heynnema
    Nov 18, 2016 at 1:02
  • @heynnema I'm sorry. I don't know if I didn't understand that or if I didn't explain well. The live USB does boot no problem, but the ubuntu installed on my hard drive isn't booting. By running ubuntu from a liveUSB I am able to delete the file that I created before the installed Ubuntu stopped working, and also perform fsck on the sda6 partition where ubuntu is installed. I have Intel HD graphics (first i3 gen) and the drivers were up to date. I didn't have a problem until I disabled mouse acceleration by creating that file. Nov 18, 2016 at 15:43
  • Do you remember the name and location of that file that you created? Remember the contents of the file? I doubt that it caused your problem. Can you boot your normal hard disk into recovery mode successfully?
    – heynnema
    Nov 18, 2016 at 19:15
  • At the GRUB menu, hit the "e" key. This will take you into edit mode. Find the line that has "quiet splash" and change it to "quiet splash nomodeset". Then hit control-x to boot with the temporary mod in place. See if that boots.
    – heynnema
    Nov 18, 2016 at 19:20
  • @heynnema Yes, the file I created was a file to disable mouse acceleration. Using a live USB I deleted that file but the system still didn't boot. I'm gonna try to nomodset option now and let you know. Thanks! Nov 18, 2016 at 19:42

3 Answers 3


After experiencing this exact same issue, using Ubuntu 16.04.02, I found a couple of ways to work around it. It seemed my problems were caused by changing the graphics nvidia drivers, and although I haven't found a way to properly work the drivers, I can get the regular login operation working again.

  1. First Fix.

    • I used ESC on the startup ubuntu purple splash to be able to enter GRUB.
    • Using e to edit the grub ubuntu boot command, I added the command nomodeset to the line starting with linux, just before other commands quiet splash. See this for an example.
    • At the Ubuntu Login Screen, I got caught into a login loop, where the same startup process was obviously being called. To get past this, using CTRL + ALT + F1 you can login and enter a terminal.
    • Use sudo apt-get purge nvidia* to remove the unusable graphics drivers. Can be installed again later if need be. (ie, here)
  2. Second Fix (Context: After achieving sucess with the first method, I proceeded to reinstall nvidia drivers to attempt to get the working again. Doing so, I also restarted xserver as described here which ended up breaking my login process, and even with nomodeset still resulted in the same issue.) Looks like the GIF in this.

    • To get past this block, I needed to boot into a recovery mode configuration of Ubuntu.
    • Use ESC on the startup ubuntu purple splash to be able to enter GRUB. Select Advanced options for Ubuntu.
    • Selected Root option to drop to a root shell prompt.
    • Use sudo apt-get purge nvidia* to remove the unusable graphics drivers.
    • Use Method 2 to reset xserver dependencies. This is because xserver hosts nouveau drivers for graphics cards.

You should now have regular access to your Ubuntu instillation, but I can't comment on your graphics card functionality.

  • Oh, man.. I don't have that computer anymore, so I can't test this. That one had Intel graphics though. I hope this is useful for someone else in the future. Thanks for your reply. Jul 14, 2017 at 2:43

This is something that I'm still dealing with, as I just found with an Ubuntu 18.04 upgrade. It seems nVidia and Ubuntu (and Linus, and Wayland, and...) aren't really getting along at the moment, leaving us all to suffer. nVidia driver bugs are causing a lot of problems.

I had to:

  • boot after upgrade, into the same screen posted in the question
  • google google google on my phone
  • ctrl-alt-F2 to open a tty
  • sudo apt purge nvidia*
  • sudo add-apt-repository ppa:graphics-drivers
  • sudo apt update
  • work out which damned chipset i had against available drivers (ok i just picked most recent)
  • sudo apt install nvidia-390
  • sudo apt upgrade # which fixed a bunch of dependencies
  • boot, edit boot line to add nomodeset (and there's that nasty noveau driver...rrrr...)
  • And that didn't work... so I reinstalled gnome and gdm3 via: sudo apt install --reinstall gnome gdm3
  • And that got me crawling into a GNOME desktop
  • From there, I found X startup errors when running i3; I removed the previous manual /etc/X11/xorg.conf that was pointing at nvidia; and finally I had my i3 window manager again.

You may try to upgrade the system to 18.04 using tty1.

I ran into the same error message when I tried to upgrade my ubuntu from 14.04 to 16.04. There was no error message during the upgrade process in the 14.04 system. But the computer can't enter the graphic interface after the reboot required by the upgrade. The desktop stuck at the fsck screen similar to the photo posted in the question.

I tried to install the most recent nvidia driver nvidia-430. After the install, I stuck at the message "starting lsb: vpn client from palo alto netwrks globalprotect" right after the fsck result. Reset xserver also doesn't help.

Eventually, I switched to tty1 and upgrade the system to 18.04. I am able to enter the graphic interface right after the upgrade and a reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.