12

I'm using Ubuntu 11.10 on Dell Inspiron N5110. As the touch pad is a bit large in this model it’s frequently getting in my way while typing. Although I try my best to not touch it, the cursor still gets moved and ruins what I am typing.

I remember an option in the "Mouse and Touchpad" utility which let us lock the touchpad while we are typing but I couldn't find that option in this utility now.

Any clue?

15

Use syndaemon to disable while typing. Syntax is syndaemon [-i idle-time] [-d]
So something like syndaemon -i 4 -d Or, you could disable it completely with this command synclient TouchpadOff=1
Add them to your startup applications

2
  • 1
    This solution works with all Desktops and Window Managers, xubuntu lubuntu kubuntu, gnome xfce kde fluxbox icewm. Great job.
    – Sepero
    Jul 1 '12 at 23:44
  • 3
    syndaemon -i .5 -K -t -R -d will just disable clicking, while allowing movement Nov 11 '13 at 16:21
5

I could fix this using dconf-editor, under org > gnome > settings daemon > peripherals > touchpad. There's an option to disable the touchpad while typing.

enter image description here

I also don't have the "touchpad" tab in system settings. Let me know if works for you.

UPDATE: I've just upgraded to Ubuntu 12.04 LTS, and the "touchpad tab" issue is fixed. At least with my laptop.

2
  • 1
    Not working under Ubuntu 14.04 LTS
    – Yasen
    Dec 9 '14 at 6:44
  • 2
    I found it in Ubuntu 18.04 under /org/gnome/desktop/peripherals/touchpad/.
    – MS Berends
    Dec 7 '18 at 8:24
4

Open System Settings.

Go to "Mouse and Touchpad"

Click on the Touchpad tab.

mark "Disable touchpad while typing."

enter image description here

5
  • 2
    I don't have the Tcouhpad tab. I do remember this tab as this is actually what I used in past but it's not available now.
    – mustu
    Dec 5 '11 at 4:22
  • what's your output of xinput list
    – martin
    Dec 5 '11 at 13:33
  • ⎡ Virtual core pointer id=2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)] ⎜ ↳ ImPS/2 ALPS GlidePoint id=13 [slave pointer (2)]
    – mustu
    Dec 7 '11 at 19:54
  • I think it has detected it as ImPS/2 ALPS GlidePoint
    – mustu
    Dec 7 '11 at 19:55
  • 1
    I have the "disable touchpad while typing" option CHECKED and still I'm having problems. What's wrong? Mine is an integrated Synaptics PS/2 touchpad. Dec 16 '12 at 14:50
1

I personally find that the mouse an touchpad settings that come with Ubuntu don't quite do the job and my mouse is always moving around. I use the following program to manually turn off the touchpad when I want. Not quite as elegant as turning off when typing, but for me much more effective.

sudo apt-get install gpointing-device-settings
0

All above suggestions did not work for me on Ubuntu 18.04. I have some touchpad settings in the Settings application, but not a checkbox to disable the touchpad while typing. I did found it with dconf-editor, but it was already enabled, making no difference.

I opened Startup Applications and added syndaemon -i .5 -K -t -R -d to turn off the touchpad 500 milliseconds (.5) after every keystroke:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.