1

I unfortunately tried to install teamviewer in ubuntu 16.04 but failed. I tried to remove most of the packages which required a dependency, using this command:

sudo dpkg --remove --force-remove-reinstreq liblzma5:i386 libc6-dbg:amd64 libpam-systemd:amd64 libgcrypt20:i386  libc6-i386 libpcre3:i386 libasound2:i386 libgpg-error0:i386 libselinux1:i386 libc6-dev:amd64 libgcc1:i386

but I got stuck here.

sayantan@sayantan-labPC:~$ sudo apt-get -f install
[sudo] password for sayantan: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libc6 libpam-systemd libsystemd0 systemd
Suggested packages:
  glibc-doc systemd-ui systemd-container
The following packages will be upgraded:
  libc6 libpam-systemd libsystemd0 systemd
4 upgraded, 0 newly installed, 0 to remove and 127 not upgraded.
3 not fully installed or removed.
Need to get 0 B/6,690 kB of archives.
After this operation, 54.3 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Preconfiguring packages ...
(Reading database ... 321169 files and directories currently installed.)
Preparing to unpack .../libc6_2.23-0ubuntu4_amd64.deb ...

LD_LIBRARY_PATH contains the traditional /lib directory,
but not the multiarch directory /lib/x86_64-linux-gnu.
It is not safe to upgrade the C library in this situation;
please remove the /lib/directory from LD_LIBRARY_PATH and
try again.

dpkg: error processing archive /var/cache/apt/archives/libc6_2.23-0ubuntu4_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.23-0ubuntu4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
sayantan@sayantan-labPC:~$ 

I checked the current LD_CONFIG_PATH, but still it doesn't help:

sayantan@sayantan-labPC:~$ echo $LD_LIBRARY_PATH
/lib/x86_64-linux-gnu/
sayantan@sayantan-labPC:~$

I even tried to force overwrite the package, but still it resulted in the same result.

sayantan@sayantan-labPC:~$ sudo dpkg -i --force-overwrite /var/cache/apt/archives/libc6_2.23-0ubuntu4_amd64.deb
(Reading database ... 321169 files and directories currently installed.)
Preparing to unpack .../libc6_2.23-0ubuntu4_amd64.deb ...

LD_LIBRARY_PATH contains the traditional /lib directory,
but not the multiarch directory /lib/x86_64-linux-gnu.
It is not safe to upgrade the C library in this situation;
please remove the /lib/directory from LD_LIBRARY_PATH and
try again.

dpkg: error processing archive /var/cache/apt/archives/libc6_2.23-0ubuntu4_amd64.deb (--install):
 subprocess new pre-installation script returned error exit status 1
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.23-0ubuntu4_amd64.deb
sayantan@sayantan-labPC:~$ 

please help resolve the problem.

  • 2
    Where and why are you setting LD_LIBRARY_PATH? it's empty by default, and its use is largely deprecated AFAIK – steeldriver Nov 17 '16 at 22:33
  • It was initially /usr/local/cuda-8.0/lib64, but for that session i changed it to what it wanted. I even tried the same after making the variable empty. The same output came up. – kenzo450D Nov 18 '16 at 0:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.