0

My HP laptop's WiFi card doesn't work.

lspci -vnn | grep Network showed:

01:00.0 Network controller [0280]: Broadcom Limited BCM43142 802.11b/g/n [14e4:4365] (rev 01)

and iwconfig returns:

lo no wireless extensions.
eno1 no wireless extensions.

I tried this AskUbuntu solution, but the following command

sudo ifconfig wlan0 up

solely returns

wlan0: ERROR while getting interface flags: No such device

2
  • What is the response to the terminal command: sudo modprobe wl Welcome to Ask Ubuntu. – chili555 Nov 17 '16 at 19:37
  • I get : modprobe: FATAL: Module wl not found in directory /lib/modules/4.4.0-47-generic – haldo Nov 17 '16 at 19:43
0

Please try re-installing the correct driver:

sudo apt-get install --reinstall bcmwl-kernel-source

If there are errors, please edit your question to report them.

Reboot.

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

Is there any improvement?

13
  • I tried that and the new response is:modprobe: ERROR: could not insert 'wl': Required key not available – haldo Nov 19 '16 at 19:12
  • Please check here: askubuntu.com/questions/762254/… – chili555 Nov 19 '16 at 20:18
  • I have disabled secureboot in bios, and did the sudo apt-get install --reinstall bcmwl-kernel-source But I still cant connect to wifi, it just says disconnect. =( – haldo Jan 2 '17 at 18:30
  • Do you now see networks? Do you try and fail to actually connect? – chili555 Jan 2 '17 at 21:16
  • Yes I can see them, but not connect "Disconnected you are now offline" it says – haldo Jan 3 '17 at 8:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.