Everytime I run Virtualbox, I cannot get any VM to run. I get this:VBox

Running it in the terminal, I get this:

WARNING: The vboxdrv kernel module is not loaded. Either there is no module
     available for the current kernel (4.4.0-47-generic) or it failed to
     load. Please recompile the kernel module and install it by

       sudo /sbin/vboxconfig

     You will not be able to start VMs until this problem is fixed.

I run that command but it did not complete successfully. I understand that there the kernel now enforces keys that each software should have in the kernel, but I do not know how to do that. Is there a step by step that I can follow so that Virtualbox(and also VMWare) works completely and fully(all functions run)? I do not want to disable SecureBoot.

marked as duplicate by user.dz, Eric Carvalho, Zanna, David Foerster, TheWanderer Nov 18 '16 at 23:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You answered your question yourself, either disable secure boot or add the signed keys manually. Otherwise no vbox ! :) I think disabling secure boot will be the best and easiest option for you ... :) – cl-netbox Nov 17 '16 at 18:37
  • @cl-netbox That's the thing, I don't know how to do that. :D Disabling SecureBoot feels wrong. That's why I would like to know how to do this. I know a lot of people have hit this. – Kency Bond Nov 17 '16 at 18:59