0

I have installed Lubuntu 11.10 for it's much lighter than Ubuntu itself with Unity, but I have serious problem. I need to put another keyboard layout- Bulgarian, but I simply can't do it. Tried a lot of things but can't figure out how to do it. Please help me for it's important. :) Thanks!

  • OP are you still looking for an answer? If so, you may need to repost your question as this is flagged for closure. =) – Ringtail Mar 7 '12 at 3:38
1

Assuming you want to use two keyboard layouts (US and Bulgarian) systemwide and switch between them using both shift keys, edit the default keyboard file:

sudo leafpad /etc/default/keyboard

Modify the file so it includes the following:

XKBMODEL="pc105"
XKBLAYOUT="us,bg"
XKBVARIANT=","
XKBOPTIONS="grp:shifts_toggle,grp_led:scroll"

Save and exit. Now when you restart, you should be able to switch between the two layouts by hitting both shift keys at the same time. If you are using a different keyboard model or want to change layouts using a different key combination, you will have to modify the relevant line(s) in the example given above.

1

In my case this command worked You have to open a terminal (Ctrl+Shift+T) and type

sudo dpkg-reconfigure keyboard-configuration

Then, when you are asked for the layout, choose Bulgarian. The latin layout will be added bu default

1

You have to add the layouts to your .bashrc file. So, let's say you wanted us and bg, run nano .bashrc, scroll to the bottom, and add the following line:

setxkbmap -layout "us,bg" -option "grp:alt_shift_toggle"

Ctrl+o to save, ctrl+x to exit.

Then logout/login, and try alt+shift.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.