1

When I right-click on an application's icon on the launcher, and select "Lock to launcher", the contextual menu never disappears. Despite that, pressing escape to get out of the menu and then closing the application does not remove the icon, suggesting to me that it "worked".

But on the other hand, when I do the same for "Unlock from launcher", the icon still remains. I don't have a way to remove the icon after it's been locked to the launcher.

Additionally, when I click-and-hold an icon for 2 seconds to move the icon, the icon appears to follow/be anchored to the cursor to allow me to move it. However, subsequently clicking the mouse anywhere does not release the icon to be moved; instead I have to right-click or press escape to cancel.

I'm sure you can imagine my frustration at this. Please help.

I have tried:

...but of course I still am unable to lock or move icons or I wouldn't be here. Any thoughts on what I might be doing wrong or how to figure out what's broken?

Are there error or message logs I can look at? Are there specific executables or permissions I can look at? What configuration files are related to the applications here?

2

Find the associated .desktop file and remove it.

Look for the .desktop file in these folders:

/usr/share/applications
~/.local/share/applications/

When you find it, remove the file with sudo rm -f file.desktop. Next time you reboot it should be gone. If you can't find it, you can always search the entire hard drive with:

sudo find / -name "*.desktop"
  • While that seems like a reasonable workaround, I would rather fix the underlying problem: that the launcher is not behaving as expected. – inetknght Nov 22 '16 at 15:45
  • I would check who owns the .desktop file. If it's own by root, your normal user won't be able to delete or modify the file. You can change the owner with chown. – Katu Nov 22 '16 at 15:48
  • I don't believe my user is supposed to own .desktop files in /usr/share/applications though? There's also several .desktop files in ~/.local/share/applications which aren't in the launcher which tells me that they should be able to be added/removed/locked/etc without removing the file – inetknght Nov 22 '16 at 16:07
  • You are right. I was referring to the files in ~/.local/share/applications/ – Katu Nov 22 '16 at 16:08
  • I edited my comment, I suspect after you'd replied. I'd added "There's also several .desktop files in ~/.local/share/applications which aren't in the launcher which tells me that they should be able to be added/removed/locked/etc without removing the file" – inetknght Nov 22 '16 at 16:09
0

It appears that the problem is the with unity. So these steps should help, open terminal then run following command:

 sudo apt-get update
 sudo apt-get install --reinstall ubuntu-desktop
 sudo apt-get install unity

if the above don't work try resetting unity using the following commands in the terminal

 dconf reset -f /org/compiz/
 setsid unity

And this should give you back the default icons if you need them

 unity --reset-icons
  • I successfully executed the commands and then rebooted. However, the problem still persists. :( – inetknght Nov 29 '16 at 15:49
  • I have updated the answer, try those and let me know. – George Udosen Nov 29 '16 at 16:30
  • I do not need the default icons. Indeed, I want to remove them. I issued dconf reset -f /org/compiz/, followed by setsid unity; the GUI reset itself and I had to log back in. The icons are still there and I'm still unable to unlock from launcher. – inetknght Nov 29 '16 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.