0

after I ran ./configure in Terminal I got this error:

configure: error: Cannot find osgEarth. At least the development version of libosgearth and the openscenegraph-plugin-osgearth package is required.

Before I started installing omnet, I had installed osgEarth via Synaptic package Manager. Does someone know how to solve this problem?

I would be very grateful for your help.

  • Did you install the development version of libosgearth? libosgearth-dev - osgEarth development files – steeldriver Nov 17 '16 at 15:01
  • Yes, also via Synaptic Package Manager. – ysief-001 Nov 17 '16 at 16:10
0

In my case the problem was related to liblzma.so.5 library. Here is how to fix it:

  1. Locate liblzma.so.5

    $ find /lib -name "liblzma.so.5 
    /lib/x86_64-linux-gnu/liblzma.so.5
    
    $ find /usr -name "liblzma.so.5" 
    /usr/local/lib/liblzma.so.5
    

    I discovered that I had 2 instances of the same library.

  2. Remove the one in /usr/local/lib and any symbolic link

    sudo rm /usr/local/lib/liblzma.so
    sudo rm /usr/local/lib/liblzma.so.5
    sudo rm /usr/local/lib/liblzma.so.5.0.3
    
  3. sudo ldconfig
    

Now ./configure did not complain about osgEarth while installing Omnet++

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.