2

I am unable to lock my screen either using CTRL-ALT-L or waiting for 5 minutes (inactive time option). After pressing the combination of keys (or waiting the 5 minutes), the screen turns off but it does not ask for any password to return to the desktop. Can anyone help me please? Thank you!

Here are my settings:

enter image description here

enter image description here

  • Go to settings->keyboard. I don't have access to Ubuntu in my office right now. There you can find option like "Shortcut". Find what is the new shortcut key for locking the system. – learner Nov 17 '16 at 12:47
  • So the important information is that the "lock" switch is shown grayed out. So it can not be activated. – Luckyrings Nov 17 '16 at 20:10
  • Can you edit your question and add the screen image for System Settings -> Power. – WinEunuuchs2Unix Nov 17 '16 at 23:47
3

I solved my problem. There was an option in the Unity Tweak Tool that was preventing any screen lock. Desktop lock checkbox must be disabled. Thanks to https://askubuntu.com/a/91719/219893

Unity tweak tool desktop lock

  • 1
    This worked for me, finally! I installed Unity Tweak Tool with sudo apt-get install unity-tweak-tool but can be found in the Ubuntu Software app. By habit I had been typing the password to launch the system back on so this was a huge vulnerability for me! Thanks @Gatuno ! – J Rivera Jan 22 '17 at 19:14
1

Enable the "LOCK" switch in the settings "Brightness and Lock" dialog.

I see that the "LOCK" switch is disabled on your screenshot.

Then it would ask for a password after blanking screen or pressing CRTL-ALT-L.

To also ask for password after standyby: Then you have to ensure that the checkbox "require my password when waking from suspend" is selected.

I have attached a screen shot of my dialog here: enter image description here

  • Lock switch is only related to his second problem (Lock screen after 'x' min). – learner Nov 17 '16 at 12:37
  • As learner says, there is no "LOCK" switch in that window and the options are disabled. In your picture you can edit the options, but not in mine. – Gatuno Nov 17 '16 at 15:15
  • 1
    What I mean is that I cannot edit the Brightess & Lock window, under the Lock section. It is not that the switch is enabled or disabled, I simply cannot change anything in that window (except for the inactivity time combobox) – Gatuno Nov 17 '16 at 15:42
  • Can you create a new user and give him a password. Check if there is possible to enable the "lock" switch? – Luckyrings Nov 17 '16 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.