0

So I am trying to mount a cifs share from Windows to Ubuntu, but I'm getting two errors on trying. First I try this from the ubuntu machine:

offensive@generalserver:~$ sudo mount -v -t cifs -o credentials=/root/.fileservercredentials //{my Windows Server IP}/Data /media/data
domain=fileserver
mount.cifs kernel mount options: ip={my Windows Server IP},unc=\\{my Windows Server IP}\Data,user=Administrator,,domain=fileserver,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I get a Permission denied error, so I read that I may have to change the security type to NTLMv2 to get it to work so I try this:

offensive@generalserver:~$ sudo mount -v -t cifs -o credentials=/root/.fileservercredentials,sec=ntlmv2 //{my Windows Server IP}/Data /media/data 
[sudo] password for offensive: 
domain=fileserver
mount.cifs kernel mount options: ip={my Windows Server IP},unc=\\{my Windows Server IP}\Data,sec=ntlmv2,user=Administrator,,domain=fileserver,pass=********
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

But now I just have an invalid argument error and I'm stumped.

Oh, and I'm suspecting that maybe encrypting data access to and from the CIFS share might be causing problems. Here's the properties dialog box for the share on Windows just in case:

SMB Share Settings 'Data'

Here are the Permissions for the share (note that I can access the share just fine from another Windows machine):

SMB Share Permissions 'Data'

I should probably mention that the Windows machine is set to a workgroup instead of a domain.

1 Answer 1

0

I found out what the problem is. As I suspected, the Data Access Encryption was the problem. When will it be a feature in Samba? I'd prefer if I could encrypt data access.

1
  • 3
    Don'd post additional questions as an answer. Ask a new one instead and refer to this one for the question and edit this answer to provide more info on what the exact blocker is...
    – Fabby
    Jan 17, 2017 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.