8

I've create three users on my computer (admin + standard users), and whenever I switch between users, my screen is turned off.

I have Ubuntu 16.10, and I switch users using the account menu on the top right corner.

Symptoms

I have two standard users who can login without a password. When I switch between them:

  • Instantly and for a brief second I see the screen of the other user.
  • The screen turns off (the LED indicator on the screen starts blinking).
  • Now there are two options:
    • The screen turns back on after a 1-3 seconds.
    • The screen stays off until I move the mouse or click on a key, as if the computer is suspended.

Additional Symptoms

When I switch to the administrative user, it is more complicated:

  • The screen blinks for a second.
  • I get the display manger where I need to enter my password.
  • The administrative user might not be selected - I have to choose it again, and enter the password.
  • I am logged in and see the screen for a brief second.
  • The screen blinks.
  • I see the display manager a second time. This time there isn't a list of users, only the administrative user. I enter the password again and log in without blinking.
  • I see an error message: System program problem detected

Things that didn't work:

  • I tried clicking on Ctrl+Alt+F7 to switch between TTY sessions. This sometimes works, but most of the times the screen still turns off.
  • I tried dm-tool switch-to-user username. This is the same as clicking the menu.
  • I tried changing the power-saving options to disable suspend mode (screen never turns off when inactive). This had no effect.
  • I tried switching the display manger to gdm3. This was terrible. The system wouldn't start and I had to use root console from grub to restore lightdm.
  • dpkg-reconfigure lightdm.
  • I tried using an HDMI cable with my graphics card (Gigabyte RX 460 2G 1212Mhz WindForce2 OC), or a VGA cable to my motherboard (ASUS H110M-K DDR4). Both behave the same.
  • I didn't try installing amdgpu-pro - it seems to support only 16.04, and isn't needed for 16.10 (which has built-in support).

Similar questions with no answers:

I will be switching users very often... How can I get this to work smoothly? Is there a log I should check?

I've found this on apport.log:

ERROR: apport (pid 19659) Fri Dec 2 12:22:40 2016: called for pid 19445, signal 6, core limit 18446744073709551615
ERROR: apport (pid 19659) Fri Dec 2 12:22:40 2016: ignoring implausibly big core limit, treating as unlimited
ERROR: apport (pid 19659) Fri Dec 2 12:22:40 2016: executable: /usr/lib/xorg/Xorg (command line "/usr/lib/xorg/Xorg -core :3 -seat seat0 -auth /var/run/lightdm/root/:3 -nolisten tcp vt10 -novtswitch")
ERROR: apport (pid 19659) Fri Dec 2 12:22:40 2016: is_closing_session(): no DBUS_SESSION_BUS_ADDRESS in environment
ERROR: apport (pid 19659) Fri Dec 2 12:22:40 2016: this executable already crashed 2 times, ignoring

I think this is related because sometimes after switching users I see the error message, and sometimes hear the error message sound.

  • Have you applied latest updates to your system ? – Soren A Dec 2 '16 at 10:47
  • @SorenA - Sure have. – Kobi Dec 2 '16 at 13:56
  • 1
    I have a similar problem, if you switch users from the login screen, the screen goes black, video output shuts off (the monitor loses signal), and usb keyboards stop responding (even when plugged and replugged - no numlock lights go on). I can still ssh in and reboot, but reviving lightdm seems a lost cause at that point... – Digikata Apr 2 '17 at 20:13
  • I think it may be a graphics card related issue. Have you installed the AMDGPU-PRO drivers? Their site mentions Ubuntu 16.04 to be compatible with their drivers so try to install these drivers (if you can) and check if the problem persists. – Anonymint May 9 '17 at 12:15
  • @Anonymint - I looked into it, and mentioned it in the question. AMDGPU-PRO explicitly doesn't support 16.10. I could have downgraded to 16.04, but I chose 16.10 specifically because it had native support for my GPU (and I chose a GPU that had drivers for Linux when I bought my new computer). – Kobi May 9 '17 at 12:38
1

Try go to settings/display and check if there is more than one monitor, and if yes turn off the monitors not in use.

  • This could have worked. I vaguely remember there being more than one screen. As I've said in the comment, I have Windows now, so I cannot confirm the solution. Definitely worth a try. Thanks! – Kobi Jul 5 '17 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.