3

I am trying to install Skype on my Ubuntu 16.04 (64bit) but I am having a hard time. After running the following to try and install it:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb
sudo apt-get -f install

I get the message shown below, which suggests removing 79 packages. I have no clue why this is happening, any help would be appreciated.

sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  adium-theme-ubuntu apturl apturl-common gcc-6-base:i386
  gnome-software-common guile-2.0-libs libasound2:i386 libasyncns0:i386
  libavahi-common-data:i386 libavahi-common3:i386 libbsd0:i386 libc6:i386
  libcap2:i386 libcdparanoia0:i386 libcomerr2:i386 libedataserverui-1.2-1
  libedit2:i386 libelf1:i386 libffi6:i386 libflac8:i386 libfreetype6:i386
  libgc1c2 libgcc1:i386 libglapi-mesa:i386 libgmp10:i386 libgpg-error0:i386
  libgssapi-krb5-2:i386 libhogweed4:i386 libice6:i386 libjbig0:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libjson-c2:i386 libk5crypto3:i386
  libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386
  liblzma5:i386 libmng2:i386 libnettle6:i386 libogg0:i386 libopus0:i386
  liborc-0.4-0:i386 liborcus-0.10-0v5 libp11-kit0:i386 libpciaccess0:i386
  libpcre3:i386 libpng12-0:i386 libpoppler-qt4-4 libqt5x11extras5
  libsamplerate0:i386 libselinux1:i386 libsndfile1:i386 libspeexdsp1:i386
  libsqlite3-0:i386 libssl1.0.0:i386 libtheora0:i386 libtiff5:i386
  libtinfo5:i386 libvisual-0.4-0:i386 libvorbis0a:i386 libvorbisenc2:i386
  libwrap0:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
  libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386
  libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386
  libxi6:i386 libxrender1:i386 libxshmfence1:i386 libxss1:i386 libxv1:i386
  libxxf86vm1:i386 mysql-common squashfs-tools ubuntu-wallpapers
  ubuntu-wallpapers-xenial zlib1g:i386
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  gcc-6-base:i386 libc6:i386 libgcc1:i386 libssl1.0.0:i386 libx11-6:i386
  libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 libxss1:i386
  libxv1:i386
Suggested packages:
  glibc-doc:i386 locales:i386
The following packages will be REMOVED:
  aisleriot appstream bamfdaemon brltty compiz compiz-gnome deja-dup eog
  file-roller firefox flashplugin-installer fwupd gdb gimp git gnome-calendar
  gnome-software gstreamer1.0-alsa gstreamer1.0-fluendo-mp3 gstreamer1.0-libav
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-bad-faad
  gstreamer1.0-plugins-bad-videoparsers gstreamer1.0-plugins-base-apps
  gstreamer1.0-plugins-ugly gstreamer1.0-plugins-ugly-amr gstreamer1.0-tools
  gtk2-engines-murrine gvfs-bin gvfs-fuse indicator-printers intel-gpu-tools
  kerneloops-daemon libappstream3 libbabeltrace-ctf1 libbabeltrace1
  libchromaprint0 libcompizconfig0 libdfu1 libfwupd1 libgimp2.0
  libgstreamer-plugins-bad1.0-0 libgtkspell3-3-0 libmagickcore-6.q16-2-extra
  libmetacity-private3a libreoffice-avmedia-backend-gstreamer libreoffice-calc
  libreoffice-gnome libreoffice-gtk libreoffice-ogltrans libreoffice-pdfimport
  light-themes nautilus-share notify-osd plymouth-label
  plymouth-theme-ubuntu-logo printer-driver-brlaser python-gtk2 r-cran-xml
  simple-scan skype:i386 snapd system-config-printer-udev texstudio-qt4
  thermald touchegg ubuntu-artwork ubuntu-core-launcher ubuntu-desktop
  ubuntu-release-upgrader-gtk ubuntu-software unity unity-lens-applications
  update-manager update-notifier virtualbox-5.1 whoopsie
  xserver-xorg-video-intel xserver-xorg-video-qxl
The following NEW packages will be installed:
  gcc-6-base:i386 libc6:i386 libgcc1:i386 libssl1.0.0:i386 libx11-6:i386
  libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 libxss1:i386
  libxv1:i386
0 upgraded, 11 newly installed, 79 to remove and 0 not upgraded.
1 not fully installed or removed.

Edit: I don't know if this helps, but if I remove skype:i386 after this, and then run apt-get -f install, I get no errors:

sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Edit: Some troubleshooting which helped with the solution (thanks @user.dz !)

Attempt 1

sudo dpkg --add-architecture amd64
sudo apt-get update
sudo apt-get autoremove
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb

Still getting errors: dpkg: dependency problems prevent configuration of skype:i386, plus a list of libs. Also, it creates the 'Error: BrokenCount>0' on Ubuntu

Attempt 2

apt-cache policy libqt4-dbus:i386

Still, errors: http://pastebin.com/ijCAJAXf

Attempt 3: gdebi

Installed gdebi, tried: sudo gdebi --o Debug::pkgProblemResolver=yes skype-ubuntu-precise_4.3.0.37-1_i386.deb

But again, dependency problems persist: http://pastebin.com/pP2k1xxF

Attempt 4

So after checking

apt-cache policy libqt4-dbus:i386

With the following result: http://pastebin.com/ijCAJAXf, tried installing the missing dependency

sudo apt-get install libqt4-dbus:i386

But still getting the unmet dependencies error:

libqt4-dbus:i386 : Depends: libqtdbus4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but it is not going to be installed 
E: Unable to correct problems, you have held broken packages.

Attempt 5: Aptitude and extra troubleshooting

Install aptitude, and tried installing the missing dependency with it (aptitude is better at working with dependencies)

sudo apt-get install aptitude
echo q | aptitude -s install libqtdbus4:i386

It still didn't manage to install it, http://pastebin.com/CNfN0dEp

The output of

apt-get -s -o Debug::pkgProblemResolver=yes install libqtdbus4:i386

is the one in here: http://pastebin.com/8yJSXtue

And also the output of rdepends

sudo apt-get install apt-rdepends
apt-cache policy $(apt-rdepends libqt4-dbus:i386 2>/dev/null | grep "^[a-zA-Z]" | sort | paste -s -d" ")

http://pastebin.com/jFDVerhr

9
  • Precise is 12.04, do you can't install that Skype package; remove it.
    – fkraiem
    Nov 16, 2016 at 0:46
  • Try sudo dpkg --add-architecture amd64; sudo apt-get update; sudo apt-get autoremove; sudo apt-get upgrade; sudo apt-get dist-upgrade; sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb
    – user.dz
    Nov 16, 2016 at 0:50
  • 1
    @user.dz Tried it, not working either. I still get an error: dpkg: dependency problems prevent configuration of skype:i386, plus a list of libs. Moreover, it creates the 'Error: BrokenCount>0'
    – J. Mac
    Nov 16, 2016 at 0:50
  • Install gdebi then post the output of sudo gdebi --o Debug::pkgProblemResolver=yes skype-ubuntu-precise_4.3.0.37-1_i386.deb
    – user.dz
    Nov 16, 2016 at 1:06
  • 1
    @user.dz Thanks for your help :) This is what I get from it: pastebin.com/pP2k1xxF
    – J. Mac
    Nov 16, 2016 at 1:11

1 Answer 1

2

After some (a lot of actually) help from @user.dz, I could find out the problem.

The problem was here:

The following packages have unmet dependencies: 
libdbus-1-3 : Breaks: libdbus-1-3:i386 (!= 1.10.6-1ubuntu3.1) but 1.10.6-1ubuntu3 is to be installed. 
libdbus-1-3:i386 : Breaks: libdbus-1-3 (!= 1.10.6-1ubuntu3) but 1.10.6-1ubuntu3.1 is installed. 
libsystemd0 : Breaks: libsystemd0:i386 (!= 229-4ubuntu10) but 229-4ubuntu4 is to be installed. 
libsystemd0:i386 : Breaks: libsystemd0 (!= 229-4ubuntu4) but 229-4ubuntu10 is installed. 
gcc-5-base : Breaks: gcc-5-base:i386 (!= 5.4.0-6ubuntu1~16.04.2) but 5.3.1-14ubuntu2 is to be installed. 
gcc-5-base:i386 : Breaks: gcc-5-base (!= 5.3.1-14ubuntu2) but 5.4.0-6ubuntu1~16.04.2 is installed. 
libgcrypt20 : Breaks: libgcrypt20:i386 (!= 1.6.5-2ubuntu0.2) but 1.6.5-2 is to be installed. 
libgcrypt20:i386 : Breaks: libgcrypt20 (!= 1.6.5-2) but 1.6.5-2ubuntu0.2 is installed. 
libstdc++6 : Breaks: libstdc++6:i386 (!= 5.4.0-6ubuntu1~16.04.2) but 5.3.1-14ubuntu2 is to be installed. 
libstdc++6:i386 : Breaks: libstdc++6 (!= 5.3.1-14ubuntu2) but 5.4.0-6ubuntu1~16.04.2 is installed. 
libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.48.1-1~ubuntu16.04.1) but 2.48.0-1ubuntu4 is to be installed. 
libglib2.0-0:i386 : Breaks: libglib2.0-0 (!= 2.48.0-1ubuntu4) but 2.48.1-1~ubuntu16.04.1 is installed.

Notice how each package (except for libdbus-1-3 (amd64)) has conflict with its libdbus-1-3:i386 (i386 component), because they should be the same version. apt-get does not solve some cases that need downgrade of a package, however,aptitude does provide such advanced solution.

Trying

sudo apt-get dist-upgrade

Did not produce any output (0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded), and I couldn't install the missing dependency manually either, as sudo apt-get install libdbus-1-3=1.10.6-1ubuntu3.1 libdbus-1-3:i386=1.10.6-1ubuntu3.1 returned E: Version '1.10.6-1ubuntu3.1' for 'libdbus-1-3:i386' was not found.

And then, apt-cache policy libdbus-1-3:i386 returned

libdbus-1-3:i386: 
Installed: (none) 
Candidate: 1.10.6-1ubuntu3 
Version table: 
1.10.6-1ubuntu3 500 
500 archive.ubuntu.com/ubuntu xenial/main i386 Packages

Letting us know that the update and security repositories weren't enabled. The solution was to enable them and install the missing dependency with aptitude.

Solution

1. Enable security & updates repositories

In System Settings>Software and Updates>Updates, enable both: Enable security & updates repos

2. Update and dist-upgrade

sudo apt-get update
sudo apt-get dist-upgrade

3. Install the missing dependency

sudo aptitude -s install libqtdbus4:i386 

4. Install Skype!

sudo aptitude install skype

I hope this can help someone, thanks @user.dz again :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.