12

I have a problem with Google Chrome on my 16.10 laptop. When I have at least one Google Chrome window open at different workspaces, Chrome gets very sluggish. Interestingly this is only the case if certain websites are shown in one of the windows. I was not able to find out whats the specific trigger, but it might have something to do with flash or html5. It's certainly the case for Youtube and Google Maps, but also for dict.cc which shows advertisement. When I have one of this sites open but have the window minimized, there is no problem.

I testet this also with Firefox, but everything works fine in this case.

Maybe someone has an idea?

Thanks!

2
4

The problem was solved when I deactivated hardware acceleration. The scrolling is still just a little bit less smooth when YouTube is running on another workspace but this is hardly noticeable.

3
  • How did you do that exactly? – colan Apr 18 '17 at 20:11
  • I turned off hardware acceleration in the Chrome settings. But this produces the problem that videos in general become much less responsive. In the meantime I switched to Gnome, where the Problem does not exist. – tz39R Apr 19 '17 at 21:03
  • Here are the steps to disable hardware acceleration ccm.net/faq/… – Juampy NR May 18 '17 at 9:38
4

I'm running 16.04.02 on a XPS 13 9360 (Kaby Lake) with an Intel 915 GPU.

After upgrading the kernel from 4.4.0 to 4.8.0 (by installing Hardware Enablement Stack) I started having these problems.

I found that following work-around instructions in the bug report that fix the problem. I just added the following line at the end in my /etc/enviroment:

LIBGL_DRI3_DISABLE=1

I also tried the solution suggested in comment #31, but that messed with my external monitors so I reverted that change.

1
  • Seems to work for me too. ubuntu 16.04 xps 15 9560 – Or Duan Nov 7 '17 at 15:21
1

Enabling the DRI3 option in xorg.conf seems to have fixed the issue for me.

Ensure the DRI3 option is enabled in /etc/X11/xorg.conf. I needed to create the file with the following content:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "SwapBuffersWait" "0"
    Option      "DRI" "3"
EndSection

I'm using intel drivers, so you might need to look around to find the correct string that represents yours.

This solution saves the need to set the LIBGL_DRI3_DISABLE environment variable and you shouldn't have to run the browser without hardware acceleration.

0

For now I'm just keeping both/all windows in the same workspace. This seems less annoying than dealing with slow videos, but maybe I'll change my mind at some point.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.