0

I have one problem that I was not able to fix on my Lenovo Flex 1480. The problem is my brightness control. My brightness keyboard control aren't working.

I have tried many of the solutions on the Web and nothing has worked so far.

I have written a conf file which looks like this :

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "AccelMethod"     "sna"
    Option      "Backlight"       "intel_backlight"
    BusID       "PCI:0:2:0"
EndSection

Then I have changed /etc/default/grub to have acpi_backlight=vendor which hasn't made a change.

I have tried xbacklight, but nothing seems to work with it. I am getting a Xrandr error.

Well, this is my last hope to make this work! Thanks guys for any suggestions or help! I have hope in this community!

P.S

this is what comes out of lspci -v | grep -i -A 15 vga

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07) (prog-if 00 [VGA controller])
    Subsystem: Lenovo HD Graphics 520
    Flags: bus master, fast devsel, latency 0, IRQ 278
    Memory at d0000000 (64-bit, non-prefetchable) [size=16M]
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at e000 [size=64]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: [40] Vendor Specific Information: Len=0c <?>
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [100] #1b
    Capabilities: [200] Address Translation Service (ATS)
    Capabilities: [300] #13
    Kernel driver in use: i915
    Kernel modules: i915
0

I have added to grub GRUB_CMDLINE_LINUX="acpi_osi=Linux"

After sudo update-grub

and rebooted, xbacklight seems to be working. So I have bound keys to increase and decrease brightness. But still, it isn't working with fn+f11 and fn+f12, it seems to be undetected by the computer somehow (I tested it out with scancode).

This is a fine workaround for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.