32

To reproduce:

  1. open chrome,
  2. open a new window (ctrl-n),
  3. move that window to a different workspace,
  4. use chrome normally (i.e. open and close new tabs, type into omnibar).

Google Chrome will behave extremely slowly.

This is only after upgrade to Ubuntu 16.10. However Chrome Version 55.0.2883.75 (64-bit).

Happy to dig deeper and post logs, etc., but don't really know where to start.

EDIT: Just upgraded Chromium to Version 55.0.2883.87, now Chromium also has the same problem.

2

I recently had a similar issue after updating and upgrading. The problem for me was related to CPU clocking speed. You might give this a try.

  1. Disable intel_psate. You can do this by modifying /etc/default/grub and adding intel_pstate=disable parameter to the GRUB_CMDLINE_LINUX_DEFAULT line. It should look like this: GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash intel_pstate=disable". Then save the file and run sudo update-grub.
  2. Install cpufrequtils package: sudo apt-get install cpufrequtils.
  3. Edit /etc/init.d/cpufrequtils file and set the following line to the governor you need (performance in my case): GOVERNOR=”performance”
  4. reboot
  • It should be 'disable' – Shane Mar 8 '17 at 5:27
  • OK I edited. Btw this answer is very hardware specific. – Zanna Mar 8 '17 at 5:34
  • Thanks and yes it is applicable to someone running an Intel processor. This can be seen by running lscpu. I will mention that if it comes up again. – Shane Mar 8 '17 at 5:39
  • 3
    Thanks, however I don't feel like I should have to mess around with hardware settings to make chrome work, especially if Firefox and older versions of chrome work fine. This should be an issue fixable within Chrome alone, should it not? – cyniphile Mar 8 '17 at 15:15
  • Agreed but if you did a complete update and upgrade to the entire system like stated in the OP, then more than just the programs were downloaded and installed. At any length, it wouldn't hurt to do it for testing purposes. – Shane Mar 8 '17 at 16:29
1

Since you have little detail about your setup I will make some assumptions.

1) you are not using the unity desktop, but something like Gnome Classic. I use flashback/fallback with Metacity, No Compiz compositor or editor to get the 'workspaces' in a row along the bottom panel.
2) maybe you only have 4 GiB for RAM?

To overcome some of the same difficulties I first increased my HP ProBook 440 G1 Laptop to 8 GiB of RAM by adding a 4 GiB stick of the exact same RAM. My CPU (i3) already has 4 cores @ 2.4 GHz., so I was good there.
I find with Modern OS's and App's 4 GiB's of RAM is not an acceptable amount of RAM.
My desktops boxes have 16 and 32 GiB of RAM as you can never have enough RAM
I used System Profiler and Benchmark available in the Ubuntu-Gnome 14.04.5 Software Center to find "How my Setup was doing?" When Version 16x first came out I found too many applications were Missing or not Working in the Software Center (perhaps this has been fixed by now), so I opted-out and reinstalled "Ubuntu-Gnome" 14.04 (not just Ubuntu, but the one with the Gnome included). I have my particular likes!
I used System Monitor to see what was running that I did not need or want.
I answered a post (Why is zero swap being used on my setup?), where there is a discussion about Memory use and I had some Ideas to look at. One of the thins I do is covered in How do I add/remove the "hidden" startup applications?.
One thing I learned is that Firefox uses Ram and Cache as one monolithic Block and Google-chrome or Opera Browser setup multiple Blocks. Not sure what is better as many debate this?, But I have found, both have a greedy approach to keep stuff in Cache and some RAM just in case you might ever use it again... in effect never releasing the former so other operations/app's might use it!!!

In Summery... Control your startup App's
Some are not visible so you will want to edit "someDesktopApp.desktop" (note you need to be in a 'root' file mode to see the *.desktop extension) and change them from

NoDisplay=false/NoDisplay=true

(link above). You do not need yet another App to control startups as once visible you can check them Off with the menu
Applications >> System Tools >> Preferences >> Startup Applications
Don't go crazy and turn too much off at once, as you may kill something you need or an indicator you want!! do some research on what does what.

Get rid of things like "animations" and other "Eye Candy" The only effective way I have found is to learn and understand "dconf Editor" (A pain in the a*$ and needs much improvement). Try ctrl+F to find stuff.

Try my way to clean the Cache. Some say NOT!!!, but it works for me when things get slow and I don't have to reboot

sudo sync && sudo sysctl -w vm.drop_caches=3

I set it up as a menu item with a file and the link to:

#/bin/bash
sudo sync && sudo sysctl -w vm.drop_caches=3

[locate in /usr/local/bin]


Setup a Menu Item

[~/.local/share/applications/menulibre-clean-ubuntu-cache.desktop]
(I like menulibre better then alacarte)

[Desktop Entry]
Version=1.0
Type=Application
Name=Clean Ubuntu Cache
Comment=To free pagecache, dentries and inodes:
Icon=aptdaemon-update-cache
Exec=gksudo /usr/local/bin/clean_cache
NoDisplay=false
Categories=menulibre-favorites1
StartupNotify=true
Terminal=false

Actions=NewShortcut;

[Desktop Action NewShortcut]
Name=clean 3
Exec=sudo sync && sudo sysctl -w vm.drop_caches=3
#OnlyShowIn=Unity

In the line above... Categories=menulibre-favorites1 ... is for my personal Menu category so you might want to set it to something different

Hope this helps. Something to think about anyway
James Niland

protected by Community Jan 19 '17 at 20:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.