3

I have a new Dell XPS Developer Edition that came with Ubuntu pre-installed. One of the first things I did was install CompizConfig Settings Manager and enable work-spaces (4×4).

When I press Ctrl+Alt+, the active window shrinks to half size and moves to the left side of the screen without moving the desktop. Similar happens with Ctrl+Alt+.

Ctrl+Alt+ maximizes the current window. The only one that works properly is Ctrl+Alt+. If no windows are active, I can move between desktops no problem. Also, using Alt + Shift+Ctrl+(arrow) works just fine.

  • In CompizConfig Settings Manager, Desktop Wall is enabled.
  • in CompizConfig Settings Manager, Desktop-based Viewport Switching is disabled.
  • In KeyboardShortcutsNavigation, the shortcuts are correctly set (e. g. Switch to workspace above is set to Ctrl+Alt+). I do not see any settings in the keyboard shortcuts that conflict.

Any suggestions as to how to figure out what is overriding these settings and fix this issue?

  • Is in the launcher bar an icon with 4 desktop ? In ubuntu 16.04 you have to enable the 4 desktops in the settings and maybe CompizConfig works differently and his "rules" only apply to a desktop without windows. Or maybe some windows have the same shortcut for something else ? – Aegefel Nov 15 '16 at 20:00
  • @DavidFoerster Yes, the Alt and Ctrl keys are being pressed, as I can move around just fine if there is no active window (or if I'm also pressing shift to move a window to different desktops). – a user Nov 16 '16 at 6:03
  • Have you verified that the keyboard shortcuts for Compiz don't clash with those of a different action? I haven't used Compiz in a long time but I remember that it was easy to assign the same key combination to different actions accidentally. +1 for the detailed, well structured question btw. – David Foerster Nov 16 '16 at 9:06
  • @DavidFoerster You were right - Under "Enable Grid", keybindings for "Maximise Left", "Maximise" and "Maximise Right" were being triggered instead. If you wish to write an answer to that effect, I'm happy to mark it as the accepted answer :) – a user Nov 19 '16 at 16:41
1

Please verify that the Compiz keyboard shortcuts for your desired actions don't clash with those of a different actions. It's relatively easy to assign the same key combination to multiple actions accidentally.

Unfortunately I know of no easier way than to go through the configuration of all enabled Compiz plug-ins and check their shortcut combinations manually.

1

As mentioned by @David Forester, the conflict is within Comipiz shortcuts. The obvious solution would be to install the compizconfig-settings-manager package. However in my experience when I changed the proper key bindings using this tool something would immediately set it back.

What I found would stick is making the change with dconf, which has the added benefit of already being installed. Launch dconf and browse to org.compiz.profiles.unity.plugins.grid. When I did this the keys left-maximize and put-maximize-key where the only two defined. I had to the other two. You need to have the following values.

put-maximize-key: <Control><Super>Up
put-restore-key:  <Control><Super>Down
left-maximize:    <Control><Super>Left
right-maximize:   <Control><Super>Right

After making these changes sanity was restored for me.

As a side note, other keybindings are non-standard when using the Ubuntu version shipped by Dell. Use another machine with a vanilla install as reference and edit the keys at org.gnome.desktop.wm.keybindings.

  • This answer worked great for me, on a late 2017 Dell XPS13 that shipped with Ubuntu 16.04 from the factory. I ended up deleting the values for the keys above. See askubuntu.com/a/15438 for instructions on installing a graphical dconf editor. – achiang Jan 11 '18 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.