0

On my website i am using apache: 2.2.22 and wordpress: 4.2.10,

Since i enabled my website to have ftp access, every plugin update or installation gives me the error:

Unpacking the package…  
Could not create directory

My vhost configs:

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        ServerName www.website.com
        ServerAlias website.com

        DocumentRoot /home/website.com/htdocs
        <IfModule mpm_itk_module>
                AssignUserId ftp-user ftp-user
        </IfModule>

        <Directory /home/website.com/htdocs>
                php_admin_value open_basedir /home/website.com/htdocs:/tmp
               php_admin_value safe_mode On
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>



........
</VirtualHost>

I am making setfacl for the apache "www-data" user as rwx permission all over the "/home/website.com/htdocs" recursively,

-rwxrwxr-x+  1 ftp-user ftp-group    32  mywot23b6b47ec20c5b6cd50d.html
-rwxrwxr-x+  1 ftp-user ftp-group  7361  readme.html
drwxrwxr-x+  2 ftp-user ftp-group  4096  tracking
-rw-rwxr--+  1 ftp-user ftp-group  2085  unsubscribezoho.php
-rwxrwxr-x+  1 ftp-user ftp-group  4951  wp-activate.php
drwxrwxr-x+ 11 ftp-user ftp-group  4096  wp-admin
-rwxrwxr-x+  1 ftp-user ftp-group   271  wp-blog-header.php
-rwxrwxr-x+  1 ftp-user ftp-group  5007  wp-comments-post.php
-rwxrwxr-x+  1 ftp-user ftp-group  3687  wp-config.php
-rwxrwxr-x+  1 ftp-user ftp-group  2727  wp-config-sample.php
drwxrwxr-x+  8 ftp-user ftp-group  4096  wp-content
-rwxrwxr-x+  1 ftp-user ftp-group  3115  wp-cron.php
drwxrwxr-x+ 13 ftp-user ftp-group  4096  wp-includes
-rwxrwxr-x+  1 ftp-user ftp-group  2380  wp-links-opml.php
-rwxrwxr-x+  1 ftp-user ftp-group  3123  wp-load.php
-rwxrwxr-x+  1 ftp-user ftp-group 34241  wp-login.php
-rwxrwxr-x+  1 ftp-user ftp-group  8252  wp-mail.php
-rwxrwxr-x+  1 ftp-user ftp-group 11048  wp-settings.php

I tried to grant "777" to wp-content recursively (plugins, upgrades folders) didn't work, and tried to change the ownership to apache user "www-data", but the plugins are gone in the admin page!

Please Help!

0

Had the same issue just recently and found a fix.

You need to change permissions on the folders inside wp-content folder:

    sudo find /var/www/wordpress/ -type d -exec chmod 755 {} \;
    sudo find /var/www/wordpress/ -type f -exec chmod 644 {} \;

After you've done that, add the following to your wp-config.php file and it should work just fine.

    define('FS_METHOD','direct'); 

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.