20

I'm having a strange problem with Terminator:

The keyboard shortcuts work for the default keyboard layout (in my case, German) just fine.

But when I switch the keyboard layout using Super+Space (to Polish or English-US), they don't work any more.

Instead, e.g. Ctrl+Shift+O sends Return to the terminal.

The only shortcuts that work seem to be F11 for fullscreen and Ctrl+Shift+T for new tab.

The problem seems to concern the functionality, not the key combination:

I remapped horizontal split on F11 or Ctrl+Shift+T, and it still didn't work, while after remapping new tab to Ctrl+Shift+O, it still worked.

I'm using Ubuntu GNOME 16.4. Keyboard shortcuts in other applications work without problems.


EDIT: Tried also switching the default keyboard layout to Polish.

Now the shortcuts work for Polish layout but not for German, so it's the matter of default/non-default, regardless of the actual layout.

  • OMG that's true! I couldn't understand why sometimes I could move from one terminal to another (alt+arrows) and some other times I couldn't. It really depends on whether or not the US keyboard is active!!! alt+arrows with the italian or french keyboard writes A,B,C,D on terminator! – Ricky Robinson Nov 25 '16 at 13:33
  • I have this problem too, it is very weird. – Astrid Aug 11 '17 at 8:10
  • Is there a permanent solution for this? – Calin Oct 21 '17 at 18:47
  • Seems to be another illustration of well known bug 1226962. – N0rbert Jan 30 '18 at 18:41
0

SO. This is a bug, pure and simple.

WORKAROUND:

Most all of those functions are available by using the mouse.

Right-click in a window and you get the options to split it.

Once split, you can drag boundaries anywhere.

The entire terminator can go full-screen by clicking on the Maximize control.

|improve this answer|||||
  • This answer is strictly speaking useless to people who cannot use a mouse, e.g. because they are blind or have a motor impairment. For people without disabilities, it is a poor workaround because it is much less efficient. – IkWeetHetOokNiet Oct 23 '19 at 19:43
0

This also might be because you have german keyboard which physical layout is different than US or polish (for example the ? symbol on US software layout on nordic and German keyboards is typed by holding shift and pressing - symbol.

All regional keyboards have different layouts (with exception of modifier, function, cursor, system command and numeric keys)

Here is example of US keyboard layoutHere is example of US keyboard layout

|improve this answer|||||
0

I just encountered the same bug. The fix is very simple - purge the terminator and install it again. What I did:

sudo apt purge terminator

Reboot.

sudo apt install terminator

Even my configuration was saved, shortcuts worked once again.

P.S. Yes I know, reboot is not necessary.

|improve this answer|||||
0

First, I should mention that this behavior is not only for "terminator" and not only for "Ubuntu"! I have seen shortcuts not working in Windows and even Mac when keyboard layout is changed! So, IMHO it is NOT a bug!

We have to better understand what a keyboard shortcut, e.g. Ctrl+F does! The Ctrl is called the modifier while F is called the non-modifier key.

When they are pushed in a software, they invoke a signal. Linux terminal uses the POSIX reliable and sometimes POSIX real-time signals. You can learn more about it by typing man 7 signal in your terminal. Terminator by defualt uses GNU style signals on linux.

Terminator is a terminal emulator which means it is a software developed that gives you the functionalities of a terminal and some additional features. Like many other softwares, you can configure how Terminator behaves by modifying its config file which usually can be found ~/.config/terminator/config.

Now, if you take a look at terminator help page for its config file you can see how this file is structured. There is a specific option, try_posix_regex which setting it to True makes the terminator to try POSIX style first. Try adding the following line under global_config:

try_posix_regex = True

Here is the explanation about the option:

try_posix_regexp (boolean)
          If  set  to  True, URL matching regexps will try to use POSIX style first, and fall
          back on GNU style on failure.  If you are on Linux but URL matches don't work,  try
          setting this to True.  If you are not on Linux, but you get VTE warnings on startup
          saying "Error compiling regular expression", set this  to  False  to  silence  them
          (they are otherwise harmless).  Default value: False on Linux, True otherwise.

I have not fully tested it, but it might resolve the issue. I am still investigating if holding a modifier key, e.g. Ctrl, somehow sends information about the keyboard layout with it or not. If it does, changing the layout will modify the signal send and therefore the terminal, terminator, or nay other software may not be able to interpret it correctly.

|improve this answer|||||
  • Your answer is completely unrelated to the question. Especially the suggested solution about regular expressions for matching URLs. – macjan Mar 26 at 9:45

Not the answer you're looking for?Browse other questions tagged or ask your own question.