1

I'm having problems with my internet connection with ethernet and wifi. Recently We have changed office and now We have internet connection that the only difference is the new is a Gigabit speed. With ethernet and wifi the connection is randomly disconnected, but applet of NetworkManager keep connected, but ping not working. This only happen when I am iddle by 1 or 2 minutes, then anything command that try uses internet fails.

ping google.cl
ping: unknown host google.cl

sudo ifconfig
enp2s0    Link encap:Ethernet  HWaddr 70:8b:cd:05:0a:3f  
          inet addr:192.168.100.5  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fe80::9bc3:d8f5:a9e9:899d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7258 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5997 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4229103 (4.2 MB)  TX bytes:856374 (856.3 KB)

Trying using wifi has the same effect, then I think this is not a driver problem for r8169 ethernet. There is no log in syslog and I don't know

Some data about my system:

Ubuntu 16.04
Kernel 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:39:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Drivers

Kernel driver in use: r8169 (ethernet)
Kernel driver in use: rtl8723be (wifi)
  • These are to separate issues with Wi-Fi and Ethernet. Both have solutions. – Pilot6 Nov 15 '16 at 13:25
  • @Pilot6 I've tackled at least one of the ethernet problems, I'll let you solve the wireless problem :-) – heynnema Nov 15 '16 at 18:01
  • The OP already solved both. See their answer. – Pilot6 Nov 15 '16 at 18:24
1

The problem was not internet intermittence, but dns intermittence.

When I could not got to google.cl because of dns error issue, I done a ping to 8.8.8.8 google dns to check internet link and I got response. Then I knew the problem was related to dns.

Searching for the problem, I found that I missing dnsmasq but reinstalling it the problem was solved.

I don't understand why my default ubuntu 16.04 installation is missig for dnsmasq.

0

There's a bug in the r8169 ethernet driver that causes disconnects.

Using Synaptic, install the r8168-dkms driver (and dkms if it requests it).

  • Start Synaptic
  • click the RELOAD icon
  • click the SEARCH icon and enter r8168-dkms
  • enable for install in the results pane
  • click the APPLY icon
  • quit Synaptic
  • reboot the computer.

If you don't have, or wish to use, Synaptic... open a terminal window and type the following two commands:

sudo apt-get install r8168-dkms

and then

reboot

At the reboot, enter your BIOS and turn off secure boot.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.