0

I have Dell Precision T-3620 Workstation and I have installed ubuntu 16.04 in it. It worked well for 1 day. One Day, I had to run a command on the terminal so I pressed Ctrl + Alt + F1 before logging in. I did my work and when I restarted it, I faced a problem. When I write the password, the screen just flashes and the login screen comes again in front of me. When it asks for password, I give it. It waits for sometime and the screen bounces back to the login screen, It recognizes incorrect password and I can login through the terminal but I can't access my files and when I add the correct password, it waits and screen bounces back. Someone said to remove .Xauthority, so I pressed Ctrl + Alt + F1 and typed rm .Xauthority But it still didn't work.

Please anyone help me out.

Thanks in advance..............

marked as duplicate by Zanna, Eric Carvalho, WinEunuuchs2Unix, TheWanderer, Kevin Bowen Nov 25 '16 at 7:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I still find it unclear if you have .Xautohirty file or not. Log in via terminal and in your home directory run this command ls -la | grep Xauthority and add the output to your question – jiipeezz Nov 15 '16 at 10:40
  • This is called, a 'login loop'. Try searching on these words to see if something applies to your situation. If not, please mention more info like graphic card and the type of modification you ran while in console mode. – Marc Vanhoomissen Nov 15 '16 at 10:44
  • Hi jiipeezz, Yes, I have a .Xauthority file with a permission -rw-------. – Shreyas Jha Nov 15 '16 at 11:07
  • If you find anything, please inform or answer – Shreyas Jha Nov 15 '16 at 11:08
  • Hi Marc, my graphics card is Nvidia Geforce GTX 750 Ti – Shreyas Jha Nov 15 '16 at 11:11
1

Your card is NVIDIA graphic. I have seen many reports of problem. Have a look at this one providing a method to install other drivers: Graphic issues after installing Ubuntu 16.04/16.10 with NVIDIA graphics

Basically, the answer is to wipe out your existing NVIDIA drivers and reinstall them from a specific source. The center of this answer is :

  1. Log into your account in the TTY.
  2. Run sudo apt-get purge nvidia-*
  3. Run sudo add-apt-repository ppa:graphics-drivers/ppa and then sudo apt-get update.
  4. Run sudo apt-get install nvidia-XXX.
  5. Reboot and your graphics issue should be fixed.

The next question is what driver version is best for you (nvidia-364 as indicated in that answer, nvidia-340, nvidia-304...)? To know the existing drivers, refer to the following link: Available NVIDIA drivers It will then be a matter of trying what best suits your computer. In my case, nvidia-340 works best, in which case instruction 4 would be sudo apt-get install nvidia-340

Not the answer you're looking for? Browse other questions tagged or ask your own question.