0

I browsed for similar questions and found a few but these were old and seemed to be system-specific. Hope you don't mind I ask again.

I have a DELL OptiPlex XE2 with Ubuntu 12.04 LTS installed. I am able to connect to wireless but not wired networks.

First I tried just plug the ethernet cable in (which works for windows computers so it is live), the wired network is disconnected and offline. Next, I tried to use a static IP address by (1) NetworkManager way, or (2) network/interface way, as I found on the internet, neither works.

I tried network-manager restart, ping localhost, NIC seems OK.

> sudo service network-manager restart
network-manager stop/waiting
network-manager start/running, process 8073
> ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_req=1 ttl=64 time=0.018 ms
64 bytes from localhost (127.0.0.1): icmp_req=2 ttl=64 time=0.043 ms
64 bytes from localhost (127.0.0.1): icmp_req=3 ttl=64 time=0.020 ms

I don't know what are the standard diagnosis inputs so please let me know so I could post them here. Thanks a lot in advance!

"sudo dhclient eth0" gave no output after a long while.

Network card is eth0.

ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 34:17:eb:c0:7c:bd  
      inet6 addr: fe80::3617:ebff:fec0:7cbd/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:1812601 errors:0 dropped:5557 overruns:0 frame:0
      TX packets:22373 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:180155598 (180.1 MB)  TX bytes:5596062 (5.5 MB)
      Interrupt:20 Memory:f7f00000-f7f20000 
  • 1
    The wired network might have configurations such as 802.1X on the Ethernet. It may not be working with the right data on 12,04. (12.04 is also really old, and will be end of life in a few months, so I suggest upgrading to 14.04 or newer) – Thomas Ward Nov 15 '16 at 2:38
  • 1
    Thanks, but Ubuntu 12.04.5 LTS is the latest that DELL is willing to certify to be compatible with OptiPlex XE2. – Yu Wai Nov 15 '16 at 3:01
  • I don't suggest relying solely on certifications. Consider that 12.04 is also very old, and it's 'libraries' for authentication are equally old; 14.04 will likely still work on the system... – Thomas Ward Nov 15 '16 at 3:14
  • @YuWai Yes, please do not rely on manufacturer certification. The Optiplex XE2 has a Sandy Bridge CPU and fairly standard ports/IO. Most anything that worked in 12.04 will work in >14.04. In addition, manufacturers tend not to continue updating certifications, especially on discontinued/old devices. – negusp Nov 15 '16 at 3:28
  • Are you trying to use IPV6? Maybe you need IPV4? – ubfan1 Nov 15 '16 at 4:13
0

If it "works" with your Windows station, then my first guess would be that there's some DHCP server at the other end. Have you tried running:

dhclient eth0

You said "NIC seems OK": could you paste the result of ifconfig eth0 (or whatever name your NIC has)?

  • Try to avoid asking questions in answers, and get that information via the comments. – negusp Nov 15 '16 at 2:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.