2

My Ubuntu 16.10 uses i915 driver. For some reasons I have troubles with it. So I want to force X to use VESA.

I tried:

  1. blacklist i915 in /etc/modprobe.d/blacklist.conf. Then sudo update-initramfs -u. Doesn't work.

  2. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash modprobe.blacklist=i915" in /etc/default/grub. Then update-grub2. Doesn't work

  3. Added new file 20-foo.conf in /usr/etc/X11/xorg.conf.d with content:

    Section "Device"
        Identifier      "Configured Video Device"
        Driver          "vesa"
    EndSection
    

Doesn't work.

Guys, how on the Earth one could make an OS that requires such an effort just to switch video driver? Maybe I'm doing something wrong?

  • Try adding "sisfb" to the /etc/modules file, or even renaming/moving all xorg-related config files. – negusp Nov 15 '16 at 3:11
  • Didn't work. Also tried to add vesa. Moving xorg.conf.d caused X to not work at all. – user1748526 Nov 15 '16 at 12:37
0

I had the same issue with a different card and Ubuntu 16.04.

I had luck appending a kernel parameter at boot: vga=791

The vga parameter sets the framebuffer to VESA mode 791 (1024x768 16bit).

To add kernel parameters: this answer or the wiki.

HTH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.