4

System: Ubuntu 16.04
Eclipse: Neon.1a Release (4.6.1)
Netbeans: NetBeans IDE 8.2 (Build 201609300101)

$ java -version  
openjdk version "1.8.0_111"  
OpenJDK Runtime Environment (build 1.8.0_111-8u111-b14-2ubuntu0.16.04.2-b14)  
OpenJDK 64-Bit Server VM (build 25.111-b14, mixed mode)

$ javac -version
javac 1.7.0_80

$ grails -version
Grails version: 2.3.11
  1. Netbeans issue -

Trying to create a Grails project from Netbeans leads to the following error in New project wizard

 Not all requested modules can be enabled: [Standard module
 org.netbeans.modules.groovy.kit jarFile: home/user_Me/software/netbeans-8.2/groovy/modules/org-netbeans-modules-groovy-kit.jar]

My netbeans.conf file has the following set as JAVA_Home

netbeans_jdkhome="/usr/lib/jvm/java-1.8.0-openjdk-amd64"

  1. Eclipse issue -

Using the route, new project > create new project > grails > grails project

leads to this error:

No Grails installation configured

So I tried configuring grails installation, and added grails home with following path:

/home/user_Me/.sdkman/candidates/grails/2.3.11/bin/

which still gives error:

Specified directory does not appear to be a Grails installation

Why cant I create an empty Grails project even though I can run Grails commands through terminal?

  • Update 1: Netbeans gives the same error for creation of other projects like JAVA, Maven, PHP, html and so on! – AnjaniKD Nov 21 '16 at 9:54
  • Update 2: The version conflict of java and javac (which might be the root issue of this question) was solved using accepted solution in this link askubuntu.com/questions/300564/… – AnjaniKD Nov 21 '16 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.