This question already has an answer here:

Ubuntu 16.04 wifi not connecting

Wifi not connecting on Ubuntu 16.04. When I go to network settings to turn the wifi toggle on it immediately toggles back to off.

I've tried

$ sudo service network-manager restart

as well as multiple other suggestions but nothing seems to work ...

This is what I got when I typed

$ sudo lshw -C network

into the terminal...

description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: enp7s0
       version: 0a
       serial: ec:b1:d7:df:8d:40
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8107e-2_0.0.2 02/26/15 ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:48 ioport:3000(size=256) memory:c3104000-c3104fff memory:c3100000-c3103fff
  *-network DISABLED
       description: Wireless interface
       product: Wireless 3160
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: wlp8s0
       version: 83
       serial: 34:e6:ad:9b:9c:63
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-47-generic firmware=16.242414.0 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:52 memory:c3000000-c3001fff

I don't think the card is recognised with ifconfig

enp7s0    Link encap:Ethernet  HWaddr ec:b1:d7:df:8d:40  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::18b2:f378:6027:7c2b/64 Scope:Link
          RX packets:15630 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7899 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6370690 (6.3 MB)  TX bytes:1605183 (1.6 MB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2709 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2709 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:217671 (217.6 KB)  TX bytes:217671 (217.6 KB)

but I think it's recognised in $ sudo lspci -vnn

08:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev 83)
    Subsystem: Intel Corporation Dual Band Wireless AC 3160 [8086:8070]
    Flags: bus master, fast devsel, latency 0, IRQ 52
    Memory at c3000000 (64-bit, non-prefetchable) [size=8K]
    Capabilities: [c8] Power Management version 3
    Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [40] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [140] Device Serial Number 34-e6-ad-ff-ff-9b-9c-63
    Capabilities: [14c] Latency Tolerance Reporting
    Capabilities: [154] Vendor Specific Information: ID=cafe Rev=1 Len=014 
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

Edit: $ rfkill list prints

0: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

I'd greatly appreciate any help, Thanks in advance.

marked as duplicate by David Foerster, Pilot6, Zanna, waltinator, MadMike Feb 24 '17 at 7:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Welcome to AskUbuntu , what is the output of sudo modprobe -r iwlwifi && sudo modprobe -a iwlwifi – GAD3R Nov 14 '16 at 12:39
  • 2
    Please edit your question and add output of rfkill list terminal command. – Pilot6 Nov 14 '16 at 13:01

Run in terminal

sudo tee /etc/modprobe.d/blacklist-acer-wmi.conf <<< "blacklist acer_wmi"

and reboot.

  • Thanks very much that worked!!! I no longer have to use a ethernet cable with my laptop! – Ciarán O'Mara Nov 14 '16 at 15:50

I think you are on right direction, card is not recognised in ifconfig. I suggest using ip instead of ifconfig. Try this...

ip a This will show all interfaces available. Your wifi should be listed there. If it is down then do this sudo ip link set wlo1 up.

  • I've tried this but it still says it's down after I run the command. – Ciarán O'Mara Nov 14 '16 at 15:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.