48

I've recently came back to Ubuntu from Kubuntu, but I really like Dolphin. Is there any way how to set it up as default file manager?

31

Steps:

  1. Open a terminal, e.g. using Ctrl+Alt+T

  2. Install exo-utils by running the following command in the terminal:

    sudo apt-get install exo-utils
    
  3. Run the following command in the terminal:

    exo-preferred-applications
    
  4. In the window that opens, click on Utilities

  5. On the File Manager section, click the drop-down menu arrow + Other...

  6. Find /usr/share/applications directory

  7. Adjust to show all files and select dolphin.desktop (wherever you find it)

  8. Click close

| improve this answer | |
  • 4
    I couldnt get this to work in Ubuntu 15.04. – Ubuntuser May 16 '15 at 6:20
  • 2
    Didn't work for me either on Ubuntu 14.04. – Revetahw says Reinstate Monica Mar 30 '16 at 9:36
  • 1
    Is this still valid for 16.04? Didnt seem to work for me. – M. Becerra Feb 2 '17 at 19:45
  • 7
    Not working: exo-preferred-applications /usr/bin/exo-preferred-applications: 11: exec: /usr/lib/x86_64-linux-gnu/xfce4/exo-1/exo-helper-1: not found – tribbloid Aug 30 '17 at 18:28
  • 3
    No way to get this to work on Ubuntu 18.04 either. – Raveren May 2 '18 at 6:02
32

To view the current default for opening directories:

xdg-mime query default inode/directory

To set Dolphin as default:

xdg-mime default org.kde.dolphin.desktop inode/directory

To set Thunar as default:

xdg-mime default thunar.desktop inode/directory

Run either on the terminal as regular user. If you want to set the default to another file manager, install the file manager, and find the correct .desktop file by searching in /usr/applications/ on the command-line.


Related files:

  • /usr/share/applications/defaults.list system-wide defaults
  • $HOME/.local/share/applications/mimeapps.list
  • $HOME/.config/mimeapps.list where xdg-mime saves configuration

Sources:

| improve this answer | |
  • this actually works if you are using synapse. The solution should be a combination of all the above answers. – Avinash R Feb 25 '14 at 12:16
  • 1
    Thank you, this is exactly what I was looking for. Also, if you want to set PCManFM, the file name is all lowercase, pcmanfm.desktop. – Aaron Franke Dec 15 '16 at 6:28
  • Is this still valid for 16.04? Didnt seem to work for me. – M. Becerra Feb 2 '17 at 19:45
  • This works for me with Ubuntu 16.04 and seems to be the easier solution. – Kubuntuer82 Jun 14 '18 at 10:23
  • Perfect. It is a better solution than the selected as answer because you dont have to install any other program – Joshua Salazar Sep 17 '18 at 14:38
10

This link should help you to change the file manager. https://help.ubuntu.com/community/DefaultFileManager

| improve this answer | |
  • 7
    Thanks, I visited that page, but it seemed too difficult. Fortunately thanks to your advice I checked it again and there is a one-line command (exo-preferred-applications). – cloxy Dec 3 '11 at 20:32
  • 2
    Love the "One more way - for "mousemonkeys", like me" solution :) – JoZ3 Feb 15 '12 at 18:49
  • Actually this script only works for setting thunar as default. If you want to set Dolphin as default it is a little more involved than this. This script only alters the .desktop files in the /usr/applications folder but dolphin by default works with the konsole terminal so you will run into tons of problems by making it default. many of it's functions will not work and I don't know the work arounds. – Joshua Robison Jul 27 '12 at 9:56
  • 3
    I used the option exo-preferred-applications to set up Dolphin as the default and everything went smoothly. I had Konsole already installed by the way. – Gabriel Jul 30 '12 at 17:21
6

Adding to Rucent88 answer:

For me the dolphin desktop file was stored in /usr/share/applications/org.kde.dolphin.desktop. So

xdg-mime default org.kde.dolphin.desktop inode/directory

did the trick.

Keep in mind to have a look where the desktop link is located. Have a look at the file list of your installed file manager to see how the desktop link is called if you can't find it.

| improve this answer | |
  • 2
    If this is an addition, perhaps you should suggest an edit to it. – muru Apr 17 '17 at 8:26
1

also it works only with:

xdg-mime default dolphin.desktop inode/directory application/x-gnome-saved-search

From: http://www.fandigital.com/2013/01/set-nemo-default-file-manager-ubuntu.html

| improve this answer | |
  • The link seems to be broken. – Flimm Aug 1 at 13:56
  • Hi Flimm the link is down – Indacochea Wachín Aug 8 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.